Pear installation package error


I am new to the Qiime and bioinformatic pipelines. I am just wondering if anyone has any experience about pear installation. I tried to install pear through the Terminal but it keep saying that: Unable to locate package pear! I tried to remove and install the whole pear file again from the website but still the same error!!

Thank you for your help in advance.

Have a good one.

Bioconda has a lot of bioinformatics tools and is easy to use for installation, you might try checking there for PEAR:

1 Like

Thank you for your great suggestion :v:

Hello again.

I am running pear to merge my sequences which are 288 sequences that each has F and R. So I have tons of sequences that want to merge. And I am using scripts below to merge them;
pear –f *_R1_001.fastq.gz –r *_R2_001.fastq.gz –o merged.fastq

And I am trying for one individual first to see how it goes.
But it gives me an error; [ERROR] - cannot open file _R1_001.fastq.gz and also for R2 as well!

I tried to unzip it first but it didn’t work as well! Though pear supposably should read it!?

Thanks again for the help.

PEAR isn’t magic, you need to add the sample names in! :grinning:

Something like this should work:

for f in *_R1_001.fastq.gz ; do

r=$(sed -e "s/R1/R2/" <<< "$f")
s=$(sed -e "s/_R1_001.fastq.gz/""/" <<< "$f")

echo ====================================
echo Processing sample $s
echo ====================================

pear \
    -f $f \
    -r $r \
    -o $s.merged.fastq.gz

Hopefully this works?



Thank you for your reply. But that is not the case here. Bc I even insert the name of the sample, just one of them.It still gives me the same error that file cannot be opened!

Although the usage of sed command is not clear for me! I ran it and didn’t work.

Thank you for your help.

Any chance you can post an example of your samples? eg 1 forward 1 reverse just a few sequences from each?