PD Mouse tutorial error in generating phylogenetic tree

I am doing the Parkinson mouse tutorial , following the workshop in youtube I am on the Generating a phylogenetic tree part

I copied the command from the tutorial page
qiime fragment-insertion sepp
--i-representative-sequences ./dada2_rep_set.qza
--i-reference-database sepp-refs-gg-13-8.qza
--o-tree ./tree.qza
--o-placements ./tree_placements.qza
--p-threads 2

and got this:

Plugin error from fragment-insertion:
Command '['run-sepp.sh', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-1010sjei/1274e2a0-61a4-4bfc-83e8-ee01c4e6b9ec/data/dna-sequences.fasta', 'q2-fragment-insertion', '-x', '2', '-A', '1000', '-P', '5000', '-a', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-at8d7yav/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/aligned-dna-sequences.fasta', '-t', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-at8d7yav/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/tree.nwk', '-r', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-at8d7yav/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/raxml-info.txt']' returned non-zero exit status 1.**

Debug info has been saved to /var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-q2cli-err-y7xsfg5j.log

1 Like

Hi @EugeniaSH,

Thanks for reaching out! Before we dive into this, can you please provide the following details:

  • Version of QIIME 2 you are running, and how it is installed (e.g. Virtualbox, conda, etc.)
  • What is the exact error message? If you didn't run the command with the --p-debug and --verbose flags, please re-run and copy-and-paste the results.

Thanks!

Sorry for the late response.
I have installed qiime2-2020.6 via conda
First question => should I install the newer version?
Second - This is what I did

qiime fragment-insertion sepp \
  --i-representative-sequences ./dada2_rep_set.qza \
  --i-reference-database sepp-refs-gg-13-8.qza \
  --o-tree ./tree.qza \
  --o-placements ./tree_placements.qza \
  --p-threads 3 \
 --p-debug \
 --verbose
Execution of SEPP failed with exit code 1
temporary working directories are NOT deleted for further inspection:
  $tmp = /var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/sepp-tmp-XXXXXXXXXX.4oIcT2KU
  $tmpssd = /var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/sepp-tempssd-XXXXXXXXXX.Myw73Oxq
Content of STDOUT -
Content of STDERR -
Traceback (most recent call last):
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/bin/run_sepp.py", line 3, in <module>
    from sepp.exhaustive import ExhaustiveAlgorithm
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/sepp/exhaustive.py", line 6, in <module>
    from sepp.algorithm import AbstractAlgorithm
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/sepp/algorithm.py", line 11, in <module>
    from sepp.tree import PhylogeneticTree
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/sepp/tree.py", line 23, in <module>
    from dendropy import Tree, Taxon, treecalc
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/dendropy/__init__.py", line 24, in <module>
    from dendropy.dataio.nexusprocessing import get_rooting_argument
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/dendropy/dataio/__init__.py", line 20, in <module>
    from dendropy.dataio import newickreader
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/dendropy/dataio/newickreader.py", line 27, in <module>
    from dendropy.utility.textprocessing import StringIO
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/dendropy/utility/textprocessing.py", line 40, in <module>
    ENCODING = locale.getdefaultlocale()[1]
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/locale.py", line 562, in getdefaultlocale
    return _parse_localename(localename)
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/locale.py", line 490, in _parse_localename
    raise ValueError('unknown locale: %s' % localename)
ValueError: unknown locale: UTF-8

Traceback (most recent call last):
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/q2cli/commands.py", line 329, in __call__
    results = action(**arguments)
  File "<decorator-gen-305>", line 2, in sepp
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/qiime2/sdk/action.py", line 245, in bound_callable
    output_types, provenance)
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/qiime2/sdk/action.py", line 390, in _callable_executor_
    output_views = self._callable(**view_args)
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/q2_fragment_insertion/_insertion.py", line 77, in sepp
    debug)
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/site-packages/q2_fragment_insertion/_insertion.py", line 53, in _run
    subprocess.run(cmd, check=True, cwd=cwd)
  File "/Users/eugenia/opt/miniconda3/envs/qiime2-2020.6/lib/python3.6/subprocess.py", line 438, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['run-sepp.sh', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-bem8sunk/1274e2a0-61a4-4bfc-83e8-ee01c4e6b9ec/data/dna-sequences.fasta', 'q2-fragment-insertion', '-x', '3', '-A', '1000', '-P', '5000', '-a', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-gmgcklum/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/aligned-dna-sequences.fasta', '-t', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-gmgcklum/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/tree.nwk', '-r', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-gmgcklum/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/raxml-info.txt', '-b', '1']' returned non-zero exit status 1.

Plugin error from fragment-insertion:

  Command '['run-sepp.sh', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-bem8sunk/1274e2a0-61a4-4bfc-83e8-ee01c4e6b9ec/data/dna-sequences.fasta', 'q2-fragment-insertion', '-x', '3', '-A', '1000', '-P', '5000', '-a', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-gmgcklum/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/aligned-dna-sequences.fasta', '-t', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-gmgcklum/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/tree.nwk', '-r', '/var/folders/9z/z0zfq8fj0n5dc4ssvtcp8wkr0000gn/T/qiime2-archive-gmgcklum/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/raxml-info.txt', '-b', '1']' returned non-zero exit status 1.

See above for debug info.

(qiime2-2020.6) [email protected]_64-apple-darwin13 mouse_tutorial %

THANKS

@EugeniaSH,

Thanks for providing all of these details! My first recommendation here would be (as you posed) to install the latest version of QIIME 2 - this may resolve the issue you're running into! Let's have you at least try that, and then we can troubleshoot from there if you're still running into the same error message.

Here's where you'll find the install instructions for the latest version of QIIME 2:
https://docs.qiime2.org/2021.11/install/native/#how-do-i-update-to-the-newest-version-of-qiime-2

Once you've done that, go ahead and run the exact same commands as you did above (including the --p-debug and --verbose flags) and let me know if you run into the same issue!

Cheers :lizard:

Thanks . I will try that immediately.
How often would you suggest updating qiime2 versions?

1 Like

Hi @EugeniaSH,

Thanks! We typically recommend keeping your version up to date with our newest release - we typically have about four releases per year, which will always be announced here and will also be listed under our installation instructions.

With that being said, I took another look over your output above, and this error message is where the problem is coming from:

This error message is related to the default language that is currently set (or may not be) on your machine. You can double check what your LANG environment variable is set to with the following command:

env | grep -i LANG

If it's not currently set (or set to something that doesn't end with .UTF-8), you can update the default value of the LANG variable on your machine, which should resolve this error.

Details on how to update this environment variable can be found in this thread (which resolved a similar issue for the original poster). Hopefully this helps you to move forward in your pipeline, but let us know if you are still running into any issues!

Cheers :lizard:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.