PCOA Biplot - Not showing every feature


I am trying to get a pcoa biplot. I already get to the step and got the biplot.qza file. However when i tried to generate visualization, it only shows some of the features, not every feature. How do i fix this issue?


Hi @Victoria_Alexandra,

I believe by default the biplots only show 5 features (at least based on this previous discussion). There is no easy way to change the default in qiime2 but you could always create your own branch of the tool and manually change those settings. You can also export your data outside of qiime2 into R for example then you would have much more control over those settings.


Agreed, I was able to do it Python as well

1 Like

Hi! @Mehrbod_Estaki, @Victoria_Alexandra
Default 5 features were enough for me, so I left it without changing. But if you change 5 in this code, will it change the number of features displayed?

        qiime diversity pcoa-biplot \
            --i-pcoa pcoa_results.qza \
            --i-features rel_tab.qza \
            --o-biplot biplot.qza
        qiime emperor biplot \
            --i-biplot biplot.qza \
            --m-sample-metadata-file metadata.tsv \
            --p-ignore-missing-samples \
            --p-number-of-features 5 \
            --o-visualization biplot.qzv
1 Like

It certainly looks that way @timanix, thanks for pointing that out! I wonder if that’s a new addition, certainly worth the try then @Victoria_Alexandra, sorry about the misleading!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.