p-exclude not working in qiime taxa filter-table

Hi there,

I'm trying to exclude certain taxa using qiime taxa filter-table, but it's not excluding the taxa input I'm providing. My other sample sets seemed to not have this issue.

Here is what I'm using:

qiime taxa filter-table
--i-table filtered-clones-taxonomy.qza
--i-taxonomy vsearch-taxfungi-clones.qza
--p-exclude "k__Fungi;p__Fungi_phy_Incertae_sedis;c__Fungi_cls_Incertae_sedis;o__Fungi_ord_Incertae_sedis;f__Fungi_fam_Incertae_sedis"
--o-filtered-table filtered-clones-fungaltaxonomy.qza

I've also tried simply: --p-exclude "k__Fungi;p__Fungi_phy_Incertae_sedis" which also did not work.

I've skimmed the forums and --p-exact doesn't seem to work with the following error: (1/1?) No such option: --p-exact
Any help is greatly appreciated.

Hi @lucky_endophyte ,

The parameter should be --p-mode exact (the parameter name might have changed over time, fyi, in case you are following an old tutorial on the forum).

I am not sure that you want exact mode, though, as that will only filter features that exactly match the entire string. It sounds like maybe you want to filter anything that includes the term p__Fungi_phy_Incertae_sedis?

As for why it is not working — check the taxonomy carefully. You might be missing a space, an underscore, or have a small typo (even a capitalization error). I suggest using this to keep it simple, if this fits what you want to do: --p-exclude "p__Fungi_phy_Incertae_sedis

1 Like

Hi there, simplifying seemed to work! Thank you so much.