Output problem from 'qiime vsearch cluster-feature-closed-reference'

Dear All,

I encountered an unexpected problem regarding output of ‘cluster-features-closed-reference’ a few days ago.
My command line is as follows,

(qiime2-2018.6) [email protected]:~/ID_server/vaginal_microbiome/vag2$ qiime vsearch cluster-features-closed-reference --i-table vag2_dereplicate_table.qza --i-sequences vag2_dereplicate_seqs.qza --i-reference-sequences …/…/…/DB/eztaxon/eztaxon_qiime_full_V3-V4_ref.qza --p-perc-identity 0.97 --output-dir ./vag2_cluster_closed_97 --o-unmatched-sequences vag2_unmatched.qza --p-threads 30

I expected 3 output from this command.

  1. ./vag2_cluster_closed_97/clustered_table.qza
  2. ./vag2_cluster_closed_97/clustered_seqs.qza
  3. vag2_unmatched.qza

However I just got a ‘clustered_table.qza’ file. I don’t know why .seq.qza and unmatched.qza files did not show in output folder. Actually, this is not the first time. I have had similar situation several times.
Have you had a similar experience? or do you have any ideas about this?

Thanks,
SL

Hey there @SLee!

I just tried to reproduce, using the OTU Clustering test data:

qiime vsearch cluster-features-closed-reference \
  --i-table table.qza \
  --i-sequences rep-seqs.qza \
  --i-reference-sequences 85_otus.qza \
  --p-perc-identity 0.85 \
  --output-dir closed_ref \
  --o-unmatched-sequences unmatched.qza

The command successfully ran, and printed the following:

Saved FeatureTable[Frequency] to: closed_ref/clustered_table.qza
Saved FeatureData[Sequence] to: closed_ref/clustered_sequences.qza
Saved FeatureData[Sequence] to: unmatched.qza

If I run a tree in my current directory:

tree
.
├── 85_otus.qza
├── closed_ref
│   ├── clustered_sequences.qza
│   └── clustered_table.qza
├── rep-seqs.qza
├── seqs.fna
├── seqs.qza
├── table.qza
└── unmatched.qza

Looks like all three artifacts are there, where they should be!

Is it possible you lost track of which file is which? Maybe try again, but specify all new locations, somewhere that is a brand-new working environment, just to keep things straight. If that doesn't help, please send us the files necessary for us to re-run the command you provided above.

Thanks! :qiime2: :t_rex:

1 Like

Hi Matthew,

Thank you for your kindly response.
As you mentioned, I tried to rerun example set using OTU Clustering test data.
I could see the result ‘Saved Feature…’ of 3 lines.
And then I obtained 2 output files in ‘closed_ref’ folder likewise you.

I could not see the ‘Saved Feature…’ printed text when I analyzed before.
I had added ‘&’ in the end of command, and then I took off the terminal.
As your comment, I will rerun by specify all new locations.

Many thanks,
SL

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.