No space left on device classifier TMPDIR

Dear Qiime2 team ,
Thanks you for maintaining the forum,
I receive the well known "No space left on device " when I use classifier. I saw that a similar issue has been solved recently.How ever it is a bit beyond my limited computer knowledge.
I have tried to overwrite the "TMPDIR "
by typing
export TMPDIR = /data . By using this command I intended to override TMPDIR but it still gives the same error.
I will appreciate your kind supports regarding how to correctly change theTMPDIR environment in conda.

Hi @arsalane1978!

First off, do you have a directory on your machine at /data? You can check by running:

$ ls /data

If you see something like ls: /data: No such file or directory, then you will first need to make the directory:

$ mkdir /data

Then, you can export that environment variable:

$ export TMPDIR='/data'

You can check that the variable is set by running:

$ echo $TMPDIR

It should display /data. If not, you will need to export it again.

Give that a shot and please let us know how it goes! Good luck! :t_rex:


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.