No legend from Emperor PCA visualisation with 2019.10 .qzv

Hi, I am currently running qiime2-2019.10.

When I attempt to export PCAs from Emperor, I only get the plot and not the legend. I have tried on many different browsers and on other PCs as per a previous closed thread in addition to re-generating the .qzv from the same qiime2 version. I tried again, using a .qzv generated from qiime2-2019.7 using the exact command with the exact same data and reloaded that in to Qiime2View. I was then able to download both the legend and the plot from the visualisation. I suspect a possible bug in how the .qzv files are handled.

Hi @BuildableDuck,
This issue looks to be a known one and similar to the one posted here a little back ago. The recommendation there was to check with your popup blocker (try disabling it or whitelisting qiime2 view) or maybe try with a different browser if its still an issue.
Try those first :crossed_fingers: and we’ll go from there.


Thanks for the reply @Mehrbod_Estaki . the thread you linked was the one I was referring to. I doubt its popup blockers as I used the same browser sessions with my trial and error. I had also whitelisted the View site in one of my attempts, but it did not appear to make any sort of difference. The only thing that appeared to make a difference was an older version of qiime2.

1 Like

Thanks @BuildableDuck for trying those solutions. I’m not really sure what to offer here as a solution, let’s see if @yoshiki, the developer of Emperor has any suggestions.

Thanks for reporting this issue, I've looked into it and it looks like there's a bug. I've opened a ticket in our GitHub repository and will look to address this before the next release. Thanks for reaching out!


Many thanks for looking in to it. I’ll be looking forward to the fix.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.