Missing plugins - q2-diveristy and q2-feature-table

Hello, new to Qiime2 here. Trying to rarefy a feature table using:

qiime feature-table rarefy --i-table ~/Artifacts/table.qza --o-rarefied-table your_rarefied_table.qza --p-sampling-depth 1456

But getting the error message:

Error: QIIME 2 has no plugin/command named ‘feature-table’.

When checking installed packages using qiime info I noticed a few plugins were missing:

System versions
Python version: 3.6.7
QIIME 2 release: 2019.4
QIIME 2 version: 2019.4.0
q2cli version: 2019.4.0

Installed plugins
alignment: 2019.4.0
composition: 2019.4.0
cutadapt: 2019.4.0
dada2: 2019.4.0
deblur: 2019.4.0
emperor: 2019.4.0
feature-classifier: 2019.4.0
fragment-insertion: 2019.4.0
gneiss: 2019.4.0
metadata: 2019.4.0
phylogeny: 2019.4.0
quality-control: 2019.4.0
quality-filter: 2019.4.0
taxa: 2019.4.0
types: 2019.4.0

Application config directory
/home/qiime2/anaconda3/envs/qiime2-2019.4/var/q2cli

Tried to install manually using:

conda install -c qiime2 q2-diversity q2-feature-table

But got this error:

PackagesNotFoundError: The following packages are not available from current channels:

  • q2-diversity
  • q2-feature-table

Can Anyone help?

Hi there @igough92! Looks like somehow some of your plugins were uninstalled from your environment. Any chance you tried to install some other plugins or tools in there? That is often the cause of these issues. Anyway, why not just delete this env and reinstall? That would be the quickest way to clean things up (IMO) --- it should be pretty quick too, since the packages are all cached locally from the first install.

:qiime2: :t_rex:

Thanks @thermokarst

I ended up downloading a new virtual box and moving all my files there! Everything worked fine after that

I don’t know how in uninstalled the plug ins. Maybe when I did a local install? My environment was stuck on (base) so I added the new qiime env…

1 Like