Memory Error- Demux Qiime2 2019.4

Hi everyone!

After searching for my issues on the forum, I believe I'm actually stuck. I keep getting a memory error message while I'm trying to run demux! I'm currently running Q2 2019.4 through VirtualBox on a 32GB HP. I'm trying to demultiplex my EMP-Single-End sequences [about 275 MB] and I keep getting an error message: "Memory Error". I ran the following command:

qiime demux emp-single --i-seqs '/home/qiime2/Documents/Kaylee/2017Data/Qiimedocs/empsingleend.qza' --m-barcodes-file '/home/qiime2/Documents/Kaylee/2017Data/qiime2/sample-metadata.tsv' --m-barcodes-column BarcodeSequence --p-no-golay-error-correction --p-no-rev-comp-mapping-barcodes --o-per-sample-sequences '/home/qiime2/Documents/Kaylee/2017Data/Qiimedocs/EMPdemultiplexed.qza' --o-error-correction-details '/home/qiime2/Documents/Kaylee/2017Data/Qiimedocs/empcorrectiondetails.qza'

I keep getting this error message, even after removing some of the parameters. (see below)

Any help would be greatly appreciated!!

Thank you!

You need to allocate more resources to VirtualBox. The VirtualBox manual should guide you on how you can do this. I am guessing the defaults are probably something like 1GB of memory, because demux is usually not a very memory-intensive action. Allocate as much memory as you can and let us know how that goes!

Thank you for the reply!! I’ll be working on my VM today and I’ll keep ya updatedc! thanks!

It worked!! Thank you so much!

1 Like