Mafft error for alignment of rep-seqs


I am trying to align some sequences following the steps given in the “Moving pictures” tutorial to create a phylogenetic tree; I am using :

**$ qiime alignment mafft **
**–i-sequences rawmilk_rep-seqs.qza **
–o-alignment rawmilk_aligned-rep-seqs.qza

Apparently everything is correct, but then appears the next error:

Plugin error from alignment:

** Command ‘[‘mafft’, ‘–preservecase’, ‘–inputorder’, ‘–thread’, ‘1’, ‘/scratch/summit/[email protected]/tmp/qiime2-archive-xy8gexli/874deeab-85ae-48de-bcc1-5b091bd39378/data/dna-sequences.fasta’]’ returned non-zero exit status 1**

Debug info has been saved to /scratch/summit/[email protected]/tmp/qiime2-q2cli-err-uhpsdoaj.log

I tried to get more information with the verbose command, but the error is still the same, I did not get more information available.

What is exactly the error? What Does it mean? How can I fix it?

Thanks for your assistance.

Hi @gilberto_solano,

Sorry to hear about your trouble.

Could you share with your rawmilk_rep-seqs.qza and, if possible, the log file?


Hi Antonio, thanks, here is it

rawmilk_rep-seqs.qza (1.8 MB)

I hope this work.

It looks like this is an old trouble, maybe related to memory or an internal process in mafft, as observed here:

Hi @gilberto_solano - I am glad you found that post - I agree with your assessment. Is there a machine with more memory you could run this on? Alternatively, you could check out q2-fragment-insertion for an alternative method for building a tree.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.