Low merged percentage after running DADA2

Hello :slight_smile:
I am processing MiSeq libraries (2x300 bp) on V4 16S region (primer pair 515F-806R) with DADA2. However, I am constantly getting a low merged percentage.

Based on quality plots I first tried truncating at 250 for forward and 210 for reverse reads and retained only 20-65% reads. Then I tried some other truncating parameters (see the table below, I put a range for retained reads because I have more than 120 samples).

First 20 bp were trimmed in order to remove primers. I read some topics on the forum, and generally, the problem with merging is that there is no overlap in reads. If I calculated correctly, I should have enough overlap to merge reads.
I also tried processing only the forward reads, and the results were much better, when truncating at 240 bp 50-82% of the reads were retained.
I know that using only forward reads is acceptable, but having in mind that read quality is pretty good, I would like to do downstream analysis with paired-end reads. Do you have any suggestions on how to further improve merging percentage and any idea what could be causing problems with merging?

Hi @anna2,
What you are saying all sounds right. It looks like you have a reasonable overlap and quality.

Would you mind sharing your highest passing dada2-stats.qzv with me so that I can take a look. Like the one where you trimmed at 240/205.

Thank you!

1 Like

Hi @cherman2,
Thank you for the quick response.
Here is the highest passing DADA2 stats file:
denoising-stats240205.qzv (1.2 MB)

Hi @anna2,
Thank you!
Yeah you are right this is pretty low merging overall and all your previous steps look reasonable.
Is there any chance your primers are still in your sequence? Sometimes if primers are left in sequences it can stop sequences from overlapping.


I am setting trim-left-f and trim-left-r at 20 (primer length is 18 for forward and 20 for reverse), so primers should be removed from sequences.

Hello @anna2,

Would you mind also sharing the demux.qzv for this analysis? There could be a problem with your read length distribution.

Also, removing primers in this way is not recommended. I would explicitly remove them by using qiime cutadapt trim-paired.

1 Like

Hello @colinvwood,

Here is the demux.qzv:
demux-paired-end.qzv (322.8 KB)

I did remove primers with cutadapt in the meantime after reading several other topics on the forum, and I am running DADA2 after cutadapt right now. Thank you for the suggestion :slight_smile:

Hello @anna2,

Your read length distribution looks perfectly fine, at least as far as merging is concerned. Do you know if adapters were checked for in your sequences, either by you or your sequencing center? Otherwise, especially given the long read lengths, I would search for and remove these as well. You can do this with the same cutadapt command.

1 Like

I just checked and it looks like the adapters are still in sequences. Thank you very much!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.