Longitudinal Error message

Hey guys,

Im trying to run the feature volatility command and Im getting an error message and cant get it to work; all other longitudinal commands work fine:

qiime longitudinal feature-volatility
–i-table …/collapsed_taxa/"$comp"-table-pruned-filtered-genus.qza
–m-metadata-file $map
–p-state-column sample_time
–p-individual-id-column tree
–p-n-estimators 10
–p-random-state 100
–output-dir “$comp”-taxa_volatility_genus

“$comp” is just a variable, and entering the precise path doesnt change the outcome. Heres the error message:

Plugin error from longitudinal:

  Value must have type '<class 'int'>'

Debug info has been saved to /tmp/qiime2-q2cli-err-cbu1r1no.log

and here the logfile:

Traceback (most recent call last):
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/q2cli/commands.py”, line 329, in call
results = action(**arguments)
File “”, line 2, in feature_volatility
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 245, in bound_callable
output_types, provenance)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 484, in callable_executor
outputs = self._callable(scope.ctx, **view_args)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/q2_longitudinal/_longitudinal.py”, line 648, in feature_volatility
missing_samples=missing_samples)
File “”, line 2, in regress_samples
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 245, in bound_callable
output_types, provenance)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 484, in callable_executor
outputs = self._callable(scope.ctx, **view_args)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/q2_sample_classifier/classify.py”, line 220, in regress_samples
summary, = summarize_estimator(sample_estimator)
File “”, line 2, in summarize
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 245, in bound_callable
output_types, provenance)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 452, in callable_executor
ret_val = self._callable(output_dir=temp_dir, **view_args)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/q2_sample_classifier/classify.py”, line 383, in summarize
_summarize_estimator(output_dir, sample_estimator)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/q2_sample_classifier/utilities.py”, line 532, in _summarize_estimator
title=‘Estimator Summary’)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/q2_sample_classifier/utilities.py”, line 538, in _visualize
pd.set_option(‘display.max_colwidth’, None)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/pandas/_config/config.py”, line 233, in call
return self.func(*args, **kwds)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/pandas/_config/config.py”, line 127, in _set_option
o.validator(v)
File “/home/mfbeuq/miniconda3/envs/qiime2-2020.11/lib/python3.6/site-packages/pandas/_config/config.py”, line 772, in inner
raise ValueError(msg.format(typ=_type))
ValueError: Value must have type ‘<class ‘int’>’

Thanks in advance!
Max

Hi @mfbeuq,

Could you please take a screenshot of your metadata file?

Thanks
Qiimer

Thanks for the fast reply!
I tried both the column tree and Tree_2 to check if thats the problem already.

I am not sure but based on this description in the Docstring the values should be exclusive in this parameter --p-state-column = “Must contain exclusively numeric values.” But in your column I see the numeric values are not in order. It was only my view!

In the entire mapfile the --p-state-column sample_time does only contain numeric values, even though they are not in order. I wouldnt have thought they must be in order?

It was my own idea. You can try it. Hope it helps.

The numeric values definitely do not need to be sorted by value

@mfbeuq could you please report the pandas version installed in your environment? (type conda list pandas into the terminal) Is this a “fresh” QIIME 2 isntallation or have you done anything to the environment? I ask because the error message indicates that this is exploding at a very unusual line:

This is suggesting to me that the pandas version may be at fault?

Thanks @mfbeuq! hang in there!

P.S., I recategorized as “technical support”

Thanks for the reply!

It says:

# packages in environment at /home/mfbeuq/miniconda3/envs/qiime2-2020.11:
#
# Name                    Version                   Build  Channel
pandas                    0.25.3                   pypi_0    pypi

It is a rather fresh QIIME2 installation, besides adding my plugins, I havent done anything.

Thanks!

What else did you install? Was everything installed using conda?

I ask because it looks like you have the “wrong” version of pandas installed, and it looks like you installed it using pip. Right now I think that’s the issue, since pandas made some big changes in version 1+. The current version in 2020.11 is:

1 Like

I did a clean isntall of my qiime environment and it works jsut fine now thanks!! (the panda version is now the correct one!)

I usually install everything with conda, I dont really know where I installed something with pip.

But yeah, thanks again for the quick help!

2 Likes

excellent, thanks for confirming!

I was asking this not only to troubleshoot this instance, though — also to get a feeling for if there are any plugins out there that conflict with the current release of QIIME 2 (including the plugins in the standard distribution)… what additional plugins did you install? Or by “my plugins” did you mean one that you are actively developing?

No I had the following:

DEICODE
aldex2
qurro
songbird (that might be it, I installed it via pip!)

Thanks for confirming. Bingo, songbird is not yet compatible with 2020.11, as there is a dependency conflict related to tensorflow I believe… see here:

This is one advantage of using conda — you can install parallel environments for different QIIME 2 releases or to support plugins that clash with each other. So you can have a parallel 2020.8 environment for when you want to use tensorflow… and another for 2020.11… and maybe another development environment… etc…

Good luck!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.