LEfSE after Qiime2 new problem

Dear All,

I am newby to Qiime2, but with firum supprt I have solved a series of probem.
Thank in advance.

But I have a trouble with the LEfSE analysis. Briefly, I have follwed the indication of the Dr Bemjamin obtaining the file in txt. I have tried to modified this file adding two raws in order to include Class- Subclass but when I switch to Galaxy there is this problem:

File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/format_input.py”, line 433, in feats = add_missing_levels(feats) File "/shed_tools/testtoolshed.g2.bx.psu.edu/

I thought that y file was correctly formatted but I do not understand the problem or how to provide a correct txt.

Thanks a lot for your help

1 Like

Show us the file context or upload it. Ben

collapse.frequency.table.txt (202.3 KB)
This the file generated frim qiime2 follwing your guide.

To complete the file I follwed the instruction found on this forum: by using excel (to add the lacking information) and then saving in txt. I also controlled, example file on galaxy.
I do not understand the trouble. Is possibile that step in excel has modified the file?

1 Like

Edit your headers - you need columns that say class, sub-class, ID

09%20PM

I have modified in this way. Unfortunaty, I did not obtain any result.

Cartel1.txt (160.3 KB)

1 Like

I’m going to run it with my installed LEFSE, the huttenhower program is difficult to use. Ben

Your main problem is that it didn’t recognize your use of “,” as a “.” I did a mass replacement on your data set and I got this:

The error that you cannot see that I can only see when I run LEFSE on my local machine is this: "ValueError: could not convert string to float: “5,31E+13” In my US-centric view of the world, the LEFSE program doesn’t seem to recognize commas as decimal points.

Here is the actual file I passed. Cartel1.txt (122.4 KB)

Thank you so much for your help.
I was not able to sostitute all “,” in “.” in excel before creating the file.txt.

What LEFSE “software” do you use? , Becouse I tried on R with phyloseq object but I did not obtain any result. Additionaly, follwoing diverse tutorail on LEFSE-R-Phyloseq I am not able to have LEFSE analysis. in other words I had to use LEFSE con galaxy for this reasons.

Thank you in advance

1 Like

I installed from GitHub or bit bucket when they offered the code. Then I learned how to install it, so now I run it from a conda environment.

1 Like

Dear Ben,

I have tried with the txt file that you have provided in Galaxy.
If I discard the sub-class raw, for example, I can do the analysis, but without any result.
It is clear that one of the problem is the “,” in the file, but then I do not understand what is the mistake: class/ subclass?, define raw o column on galaxy?
I will try again strating from qiime2…(unfortunatly, some guides have been made for qiime1)

Yeah, I’ve had this debate in the past regarding classes/subclasses, if you read Segata’s publication it’s hard to interpret exactly what they mean by classes and subclasses - I think I can’t answer that for you as it would depend on your analysis. I can tell you that using the Mercurial/Github code from way back when that file runs. I get Porphorymonas with your classes/subclasses. I can go and delve into the code for you. Ben

I tried your suggestion to use mercurial/GitHub code. I would like to use phyloseq object, but it appears quit impossible in R 3.6.
LEfSe in Galaxy is not clear (data.txt or other parameters) or almost sets up for qiime1.
I would standardize my analysis from qiime2 (first stesps) to R (second steps and plotting).
Thank you in advance for your help