kill error on classify-sklearn

Hi Chris,

I downloaded another classifier from the [QIIME 2 docs] based on the qiime info generated information i.e. 2019.4.
However, after running the following command I got the “Killed” without any number.
I am running this remotely on our institute supercomputer. Does my laptop memory has to do anything with this? Could you please help me in this regard with your suggestions and advice?

Thanks,
Irshad

qiime feature-classifier classify-sklearn \

–i-classifier …/16sdatabase/silva-132-99-515-806-nb-classifier.qza
–i-reads dada2-single-end-rep-seqs.qza
–o-classification taxonomy-single-end.qza
Killed

@Irshad, we try to keep one unique question per topic on this forum, so I’ve split this post from the prior posts.

Your laptop memory shouldn’t have any effect on how the compute cluster runs, but I suspect you’re right that this is an out-of-memory error. There’s a lot of discussion in prior posts on how to work around issues like this. The first topic listed is a solid start.

Before you start tinkering, though, how much memory did you request from the cluster to run this command?

Hi Chris,

Thanks for your input and help. I got over the "Killed" error by requesting the following:
(qsub -l nodes=1:ppn=4,mem=40gb,walltime=12:00:00 -q interactive -I)
However, while running the feature classifier command, I lose internet connection as I can't browse any website. A screenshot is attached for your perusal. From this I assume that I also lose connection with the cluster, which would never allow the process to complete.

I have asked this question from the administrator (pending response), whether this has anything to do with the intensive processes I am running remotely on the cluster. I have also tried to use a wired connection but to no avail.
What do you think is happening here? Any advice?

Thanks
Irshad

@Irshad, we’ve left the realm of QIIME 2 support with this question, and this is probably best addressed to your sysadmin. Your cluster uses different scheduling/allocation software than I’ve used, but I’d be surprised if this is related to your job at all.

Anecdotally, I run linuxmint (that looks like LM Cinnamon?), and have had similar connectivity issues which only occur when connected to my institution’s VPN. I’ve found that killing the vpn process (I use htop to find/kill), turning off wireless, and turning it back on again reliably gets me reconnected. YMMV.

Good luck!
CK

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.