ITSxpress vsearch error q2-2021.11

Hi, I ran into an issue with q2-itsxpress.

I am using a fresh installation of q2 on a new AlmaLinux8, where only qiime2 miniconda environments have been installed. No other bioinformatics tools.
I added q2-itsxpress plugin to q2-2021.11 and received this error:

Plugin error from itsxpress:
Command '['vsearch', '--cluster_size', '/tmp/itsxpress_fd_zsays/seq.fq.gz', '--centroids', '/tmp/itsxpress_fd_zsays/rep.fa', '--uc', '/tmp/itsxpress_fd_zsays/uc.txt', '--strand', 'both', '--id', '0.995', '--threads', '2']' returned non-zero exit status 1.

According to a (closed) post from Aug '21, I have validated the input sequences (are ok) and checked for vsearch (it uses /opt/miniconda3/envs/qiime2-2021.11/bin/vsearch), and no other vsearch is available outside miniconda.

I also tried q2-2021.1 and q2-2019.10 (the version stated at Github for q2-itsxpress installation) tu check for version incompatibilities. Unfortunately, preiovious q2 envs created a BBmerge error.

I have attached concatenated log files from /tmp of all three tested q2 versions to this post. See sections labelled as ### q2-2019.10 etc.
Thanks for your continued support!

itsxpress-errors.txt (9.0 KB)

Hi @arwqiime - the error message indicates that you have a mismatched bbmerge in your PATH- a version of bbmerge not distributed with QIIME 2 is being invoked by the q2-fragment-insertion code. Either that means that you somehow replaced the version in your environment, or, your PATH is pulling in a different deployment of bbmerge. Hope that helps.

Hi @thermokarst - The bbmerge issue does apply to the q2-2019.10 and q2-2021.2 environments, which I testet to look for version incompatibilities. However, there seems no bbmerge present in any of these previous and in the current q2-2021.11 environment. The linux machine is 2 weeks old and no other bioinformatic tools than q2 have been installed.

$ which bbmerge
/usr/bin/which: no bbmerge in (/opt/miniconda3/envs/qiime2-2021.11/bin:/opt/miniconda3/condabin:/home/bt140047/.local/bin:/home/bt140047/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin)
Same results with activated q2-2019.10 and q2-2021.2 environments, and no bbmerge outside q2.

However, the error in q2-2021.11 points do vsearch. It is present in q2-2021.11, and I could not find any indication, that bbmerge would trigger the error.
$ which vsearch
/opt/miniconda3/envs/qiime2-2021.11/bin/vsearch

Can you confirm that q2-itsxpress is compatible with q2-2021.11 and I should try to get it running here?
Best regards,

I cannot - q2-itsxpress is a community plugin not developed by us, you'll need to check with @Adam_Rivers.

The error message is clear - the bbmerge invoked by the itsxpress script has a different api than what the script expects. The second error you're observing related to vsearch is just because the initial bbmerge fails to run, and ships an empty file to vsearch.

It sounds like the itsxpress conda package doesn't specify a bbmap pin, https://github.com/bioconda/bioconda-recipes/blob/fca9554c95763983bdc9fb06770f956b90967057/recipes/itsxpress/meta.yaml, which corroborates what I suggested above - somehow the wrong version of bbmerge is being used here. This makes sense, if there is no pin on bbmap, then you're probably getting a newer version of bbmerge installed with q2-itsxpress than what is needed. I have no idea what version is necessary, though, you'll have to check with @Adam_Rivers.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.