ITSxpress returned non-zero exit status 1

Hello,
I am trying to use ITSxpress to trim primers and remove conserved regions as it describes.
I used the following script with a SLURM submission to the HPCC at my university.
This is being run on the output of a MiSeq run 2x 300bp V3 chemistry that was demultiplexed by our sequencing core that I imported to qiime2 with a manifest.

cd /mnt/home/USERNAME/timecourse/
conda activate qiime2-2022.8
qiime itsxpress trim-pair-output-unmerged
--i-per-sample-sequences paired-end-demux.qza
--p-region ALL
--p-taxa F
--p-threads 2
--o-trimmed trimmedITSxpress.qza

Running this, I get the following error:

Plugin error from itsxpress:

Command '['hmmsearch', '--domtblout', '/tmp/local/99083/itsxpress_rlwix5pn/domtbl.txt', '-T', '10', '--cpu', '2', '--tformat', 'fasta', '--F1', '1e-6', '--F2', '1e-6', '--F3', '1e-6', '/mnt/home/USERNAME/anaconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/itsxpress/ITSx_db/HMMs/F.hmm', '/tmp/local/99083/itsxpress_rlwix5pn/rep.fa']' returned non-zero exit status 1.

Debug info has been saved to /tmp/local/99083/qiime2-q2cli-err-gzzxnfh7.log

Searching other issues people have encountered similar to this I saw mention of validating the metadata with Keemei. My metadata was valid, so I do not believe it is that.
Unfortunately, with how our HPCC operates, the debug info is being saved to a location that is deleted immediately upon the completion of the SLURM job.
From looking into things, "returned non-zero exit status 1" broadly indicates a failure in the code's execution, sometimes regarding finding files/inputs. The file ".../ITSx_db/HMMs/F.hmm" does exist in the proper location, but I cannot verify anything regarding the /tmp/ files on account of them being deleted upon job completion to my knowledge.

Unfortunately I haven't really been able to find a great answer for this by searching the forums, and the information that would help me seems to be difficult to access on account of how our HPCC operates.

EDIT: I used --verbose to get a bit more info. The holdup seems to happen with:
Error: Sequence file /tmp/local/102975/itsxpress_mb8uae5p/rep.fa is empty or misformatted

Does anyone have insights into what could be causing this with ITSxpress specifically, or this class of error in general?

Hello, welcome to :qiime2: Forum!

This is a general error. Please, take a look at sequence file
/tmp/local/102975/itsxpress_mb8uae5p/rep.fa

It causes the error. It should be within your Representative Sequences Artifact, you can extract it from QZA with an archiver software.

If you can't identify the error, you can attach it on forum somehow.

Cheers
Valentyn

1 Like

An off-topic reply has been split into a new topic: HMMER fail in q2-itsxpress

Please keep replies on-topic in the future.