Issues with running Gneiss, loading regression summary, and Firefox - view.qiime2.org compatibility

Hi

I have been tryign to run Gneiss but ran into two issues:

  1. When trying to run the ols-regression I got a zero variance balances error. I managed to overcome this after reading some posts on the forum - I filtered the table.qza with

qiime feature-table filter-features
–i-table table.qza
–p-min-frequency 10
–o-filtered-table filtered-table.qza

and then got no error for the regression. However, I wanted to ask how would one choose a sensible value for filtering?

  1. This one is a bit more confusing…I have been having issues with visualizing the regression summary.qzv in qiime view. The tables load quite quickly, but the figures don’t. I keep getting the message: “A web page is slowing down your browser. What would you like to do? Stop it/Wait”. I am running this on Firefox within the virtual box. After waiting for a couple minutes the figures load too, but I can’t really interact with the graphs because the browser freezes. Also, the heatmap is completely white, although when I hover the arrow I do get values for p-values, and the y-axis is not labelled… Do you know what the reason for this could be? I did not have this issue before with any of the other visualizations.

https://www.dropbox.com/s/54f26q6jgbb6rtv/ols-regression.qzv?dl=0 - this is the regression-summary

Many thanks :relaxed:

Hi @Alex_14262,

I am not sure there are really solid guidelines that would cover all cases; it will largely depend on a user’s own expectations about their data, and overall sequencing depth. As @mortonjt indicated in this post:

But a min-frequency of 10 seems reasonable to me as a threshold for cutting off low-abundance features.

Sounds like either:

  1. this is a memory error, due to constrained memory inside the virtual box (and/or a very large QZV). Toss the file in the shared folder and view outside — does this fix things?
  2. there is an issue with firefox (is it the latest version? is this compatible?)

I hope that helps!

1 Like

Hi,

Thanks for that! So I guess it would be sensible to filter the data following these three steps as mentioned here? I can't tell if it would be redundant running all three.

So far I have never been able to run qiime view outside virtual box as I get this message:

However, I tried using Google Chrome instead of Firefox and it seems to be working. For all this time I thought it wasn't working on my laptop because I am not running Linux :joy: . I think the issue with loading was because of the memory constrain (I have the latest version on both VB and my laptop).

Thanks

1 Like

Hi,

Running into possibly a similar issue later in the analysis so wanted to double check - when I investigate the y0 balance taxonomy and look at the visualization I get no boxplot for balances and no proportion plot. However, I can see the balance taxonomy plots. Not sure if I am doing something wrong in the analysis or it’s just simply not loading (I tried it both in my virtual box and on my laptop and it looks the same).

qiime gneiss balance-taxonomy
–i-table composition.qza
–i-tree hierarchy.qza
–i-taxonomy taxonomy.qza
–p-taxa-level 2
–p-balance-name ‘y0’
–m-metadata-file Mapping-file.tsv \
–m-metadata-category Paint
–o-visualization y0_taxa_summary_paint.qzv

y0_taxa_summary_paint.qzv (483.0 KB)

Hi @Alex_14262!

Interesting! I’ve not seen that before, but after a brief google, it looks like Firefox does some odd things when cookies are disabled for the file:// protocol, which is what qiime tools view uses. How strange! Does enabling cookies allow Firefox to work for qiime tools view?

@mortonjt, correct me if I’m wrong, but I believe those plots do not exist if you have more than 2 values in a given column of metadata. Did you see a warning indicating that when you ran that command?

@ebolyen yup that’s correct - proportion plots are currently not enabled if there are more than 2 categories. The way around this is to look at 1 category at a time.

Hello,

Thanks for the help!

@ebolyen I already have cookies enabled on Firefox:

Is that the setting you were talking about?

As for the plot, I didn't get any warning messages about it - I think it would be useful to incorporate one, because it's not made obvious that you only have to have 2 values in metadata column to get those plots. How can you filter the column so that you only have two values at a time?

Hi @Alex_14262, what version of Firefox did you try this on?

Also, can you clarify, are you trying to use view.qiime2.org, or qiime tools view? Can you provide a screenshot of the developer console opened up when the error occurs?

I will let @mortonjt answer this (and create any new issues relevant to warning messages, if he thinks that makes sense. Thanks! :t_rex:

Hi @thermokarst! I am using Firefox quantum 58.0.2 (64-bit) which seems to be the last version. I have only tried to use view.qiime2.org on my laptop since I am running windows and I can't run qiime. However, in my virtual box, view.qiime2.org works just fine, and thus, I thought it doesn't work on my Host because of Windows compatibility or something. Then, I tried using Chrome on my Host to solve the memory issue I encountered in the VB (discussed above) and view.qiime2.org worked.

Let me know if this is what you asked for. Also, this is just me trying to load view.qiime2.org . I can never get to the drag and drop stage.

Thanks! :squid:

Hi @Alex_14262!

Cool! That is exactly what view.qiime2.org was built for!

Interesting thought, but we have plenty of users of view.qiime2.org on Windows, so I don’t think it necessarily is related.

That makes sense - your host machine has access to much more RAM than your virtual machine.

You showed us the overall settings for cookies in firefox, can you please take a look at “Exceptions” there, too, and make sure that view.qiime2.org isn’t listed.

As @ebolyen mentioned above, this really looks like a browser setting issue (probably related to cookies).

Thanks!


@mortonjt, can you please reply to this question? Thanks!

2 Likes

Hi @thermokarst!

Success!!! I added the website to the list of exceptions and clicked ‘Allow’ so that the browser always allows the website to use cookies and now I can drag and drop .qzv files! Thanks so much for this!

3 Likes

That is fantastic! I’m bookmarking your post in case I see this happen to anyone else! What’s especially ironic is q2view doesn’t even use cookies. For anything at all. It seems to just be a side-effect of something else in the network stack of the browser.

Hi @Alex_14262 - I was able to connect with @mortonjt about this issue (sorry it took so long, there was some confusion about the question). Anyway, he let me know that there is apparently a warning for this situation already being raised. You can see it if you run the command with --verbose, otherwise it sounds like it might be hidden. Hope that helps!

1 Like