Installing QIIME on my Mac

Hello–I had installed QIIME back in June. Now I am trying to install again.

When I run:

(qiime2-2019.10) Andrews-Air:~ adinsmoor$ conda env create -n qiime2-2019.10 --file qiime2-2019.10-py36-osx-conda.yml

I get this error:

CondaValueError: prefix already exists: /Users/adinsmoor/opt/miniconda3/envs/qiime2-2019.10

It seems I may be having trouble activating the conda environment, following this: https://docs.qiime2.org/2019.10/install/native/#install-qiime-2-within-a-conda-environment

Thanks,
Andrew

Hi Andrew,

Could you try running conda info --envs in your terminal and paste the results here? This command will display a list of all the conda environments installed on your system.

My guess is that you already have an environment named qiime2-2019.10 installed on your system somehow (this could’ve happened in a few different ways – one likely scenario might be that QIIME 2 2019.10 is already (partially?) installed). Anyway, if this is the case, you should see qiime2-2019.10 show up in the output that the conda info --envs command gives you!

If you do see qiime2-2019.10 show up in the output, then you should be able to fix the problem by removing the environment using conda remove --name qiime2-2019.10 --all. From there you should be able to (re)-install :qiime2: properly.

Let us know if this works!

3 Likes

Thank you, that worked originally! However, when I close my terminal and re-run source “activate qiime2-2019.10” I get the following error:

(base) wirelessprv-10-194-185-112:~ adinsmoor$ source activate qiime2-2019.10

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

(qiime2-2019.10) wirelessprv-10-194-185-112:~ adinsmoor$

Hoping to do moving picture tutorial next.

Thanks,
Andrew

1 Like

Hey @adinsmoor!

Check out this error message:

I don’t think this is related to your QIIME 2 environment. A quick search turns up:

Give that a shot, hopefully that’ll sort you out.

1 Like

Sorry for major delay!

Unfortunately when I try “conda” to start my environment I get this error:

conda commands available from other packages:
env
(base) vpnpool-10-250-4-167:~ adinsmoor$

I tried this solution with no luck:

Solution

Open Terminal, and run the following:

xcode-select --install

Thank you!
Andrew

1 Like

Sounds like you haven’t finished installing conda - the final step (as laid out in their docs) is adding conda to your path, and initializing your shell. Have a read through here for more:

https://conda.io/projects/conda/en/latest/user-guide/install/index.html

1 Like

It looks like Miniconda 3 is installed, and I was able to create my condo environment using:
conda create --name myenv

Unfortunately, when I run the first line of code to install QIIME I receive (“command not found”):
(myenv) vpnpool-10-250-4-167:~ adinsmoor$ wget https://data.qiime2.org/distro/core/qiime2-2020.2-py36-osx-conda.yml

-bash: wget: command not found

Not sure what I’m missing.
Thanks,
Andrew

Good news, @adinsmoor! Thanks for updating us.

Did you finish running the first command in the install guide?

In particular, there is a step there for installing wget:

Screen Shot 2020-04-15 at 8.00.33 AM

When I run conda update conda, I am receiving this error:

PackageNotInstalledError: Package is not installed in prefix.
prefix: /Users/adinsmoor/opt/miniconda3/envs/myenv
package name: conda

Not sure what this means…

I attempted to remove and re-install today. I get to the “source activate qiime2-2020.2” and using that or “conda activate qiime2-2020.2” I receive: Could not find conda environment

My conda env. info is below:

/Users/adinsmoor/opt/miniconda2
* /Users/adinsmoor/opt/miniconda3
/Users/adinsmoor/opt/miniconda3/envs/myenv
/Users/adinsmoor/opt/miniconda3/envs/qiime2-2020.2

Any help would be appreciated! Thanks!

What do you see when you run conda env list?

You might need to move these inquiries over to the miniconda support channels, they will be better equipped to help you out in the long run.

:qiime2:

I tried removing and re-installing again and got things running!

“/Users/adinsmoor/opt/miniconda3/envs/qiime2-2020.2”

“(qiime2-2020.2) Andrews-Air:~ adinsmoor$”

Thank you for your help!

1 Like