breakaway plugin installation error


I’m trying to install breakaway using the instructions outlined here…

When I installed the breakaway dependencies I received the following error…
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Then when I tried to install breakaway and q2-breakaway I got the following error…

(qiime2-2020.8) abc6cmac:~ abc6c$ pip install git+

Collecting git+

Cloning to /private/var/folders/cr/nkn3f6j93cx5cx5y1z_61mj1l2p_md/T/pip-req-build-_kc6kvwh

ERROR: Command errored out with exit status 1: git clone -q /private/var/folders/cr/nkn3f6j93cx5cx5y1z_61mj1l2p_md/T/pip-req-build-_kc6kvwh Check the logs for full command output.

Any/all help is appreciated.


@ABCahoon, have you read the error logs? They might point you in the right direction.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.

I posted this question back in September, breakaway plugin installation error, and have been struggling off and on to solve the problem ever since. I found the solution today in this post, Installing QIIME on my Mac, specifically the need to follow this link,, where I learned that I needed to install Command Line Tools from the Apple Developer store (it was free). This solved my problem and I can now download plugins :grinning:.

I appreciate the response in the original message. I realize in hindsight that that my question would have been easier to address if I had included that I was using MacOS 10.15 Catalina as it seems to be a Mac specific problem.

Side note, this was also affecting my ability to download some packages in R and it was generally driving me bananas.


Super glad you figured this out, @ABCahoon, and thanks for sharing. I suspect some other unhappy MacOS user will appreciate the effort you put in.

Chris :zebra: