Installation error

Hi,
I am having some odd problems installing Qiime2-2019.7 on a Mac OS X 10.14.2 system. I followed the install directions, which I will reproduce here for clarity:
conda update conda
conda install wget
wget https://data.qiime2.org/distro/core/qiime2-2019.7-py36-osx-conda.yml
conda env create -n qiime2-2019.7 --file qiime2-2019.7-py36-osx-conda.yml

However, if I then type either “source activate qiime2-2019.7” or “conda activate qiime2-2019.7” my shell seems to begin quickly cycling through various programs as the title of the shell quickly shifts from python, bash, tr, sed, etc… Meanwhile, nothing happens, it will hang like this indefinitely. If I cancel the operation my prompt changes to begin with “(qiime2-2019.7)” such that it seems I am now in the correct conda environment. However, if I type “qiime --help”, I get a message saying “Activate a conda environment.” followed by argument descriptions. Note that if I deactivate the environment via “conda deactivate” my prompt returns to (base) as expected.

If I type “conda info --envs” I see “qiime2-2019.7 * /Users/joshuaharrison/miniconda3/envs/qiime2-2019.7” Therefore, I think installation was successful. Also, I can see various qiime2 python modules have been installed via “pip freeze”

Any thoughts? Some weird path error perhaps?

When in what I think is the qiime environment, if I type echo $PATH I get a lengthy series of directories that repeats itself often. Here is part of the string: “/Users/joshuaharrison/miniconda3/envs/qiime2-2019.7/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/bin:/Users/joshuaharrison/miniconda3/condabin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/opt/X11/bin:/local/bin:/bin:/Users/joshuaharrison/miniconda3/bin:/local/bin:/bin:/Users/joshuaharrison/miniconda3/bin:/local/bin:/bin:/local/bin:/bin”

This is not my normal path, needless to say. Any ideas why this duplicative path gets specified when I enter the conda environment?

I have tried uninstalling miniconda twice and reinstalling qiime2. Both times I have had the same problems. I can install Qiime fine in a virtual box, and was able to install natively on the machine I am currently using a few weeks ago. I am not sure what I would have changed in the past few weeks to cause this problem (no system updates).

Thanks for the help!

That looks spooky! I wonder if something went sour when miniconda was installed? Either way, this looks like the base installation isn’t working quite right. I would suggest double-checking your dotfiles to make sure there isn’t anything strange there, and if still having issues, remove miniconda and reinstall.

Keep us posted!

Thanks for the reply. I tried deleting and reinstalling miniconda3 a few times. No luck. I scrubbed out my bash profile before installation and removed the .conda files. Can you think of any other files that I should try removing/editing before another reinstall?

What does your bash setup look like? That PATH variable is one of the gnarliest I have ever seen before… :surfing_man: