Install phyloseq in qiime2 docker container


I’m currently trying to install the R package ‘phyloseq’ in your Qiime2 2017.12 docker container. I have tried using the conda install -c bioconda bioconductor-phyloseq=1.22.3 command. It gives me a list of the dependencies that requires endless installation.

I have also tried to install it using these two methods in the R 3.4.1:

install_github(“phyloseq”, “joey711”)


I still couldn’t install it in the container. Could you please point me to the right way to install the phyloseq package in the qiime2/core:2017.12 container?


Hi @Changsu, this is an interesting question. It gets way more into Docker-specifics than QIIME 2, so our support capacity might be a bit limited, but here are some thoughts.

My guess is it isn’t working for you, because of the nature of how docker runs: you have downloaded the QIIME 2 image, and when you run QIIME 2 commands in Docker, you actually launch a container instance, which is based on the image. One thing about Docker though is that containers are generally considered ephemeral, so after you install phyloseq, once you exit the container, your changes get deleted. The next container you launch is sourced off of the original image, so none of your changes are there. :cry:

Option 1: docker commit

After you launch a container instance and make your changes, you could experiment with docker commit - this would let you create a new image, based on our image, but with your changes added in.

Option 2: Dockerfile / FROM

You could also create a new Dockerfile that inherits from ours — then you could programmatically make your changes there.

Like I said before, this really gets into Docker territory, so we might not be your best option for helping you out with the specifics, but please keep us posted. If you come up with a strategy you like, that could make a great Community Tutorial for you to share with your fellow QIIMElings!

Thanks, and keep us posted! :t_rex:

Thanks for the answer. To clarify, I haven’t been able to install phyloseq in the Docker container. The container is still running when I try to install it but it can’t be completed. It keeps requesting more and more dependencies.


Hi @Changsu — did you check out the phyloseq installation guide? Another option is to set up phyloseq in a separate Docker container. This approach might make the most sense, that way you can just connect your Docker containers and shuffle the data back and forth between a Q2 environment and a phyloseq environment. Keep us posted!