Q2-coordinates with core release?

Hi all,
I’m not sure what level support you can offer for plug-ins featured in the new Qiiime2 Library, but I’d really love to try out q2-coordinates. Unfortunately, I’m running up against install issues. I’ve been running Qiime2 smoothly from docker for a while now. However, starting from the 2018.11 container, Conda won’t install (from within the container), and there’s no C compiler. Is there any chance this plug-in will be in the next core release? Is it possible for one of the developers to build a docker container with Qiime2 2018.11 and q2-coordinates? Or is there some other work around?
Thanks for all your work!

1 Like

Hi @aphanotus,
I am the developer of q2-coordinates and am so glad to hear that you want to use this!

With popular demand it could be… I started that plugin as a sort of side project so ideally it should be user-tested more before we could migrate to the “core release”. But if folks find this plugin really useful we could definitely migrate it (even though ultimately we are trying to step back from the idea of a “core distribution” and all plugins will be distributed on the library).

This seems like the bigger issue that should be addressed anyway — I never work with docker so we will need to wait for other QIIME 2 team members to return to the office (there is a QIIME 2 workshop this week, so responses will be delayed). Just in case there is a useful nugget of information you could check out this topic — but that’s a 2017.12 container so is probably irrelevant if some new issue is preventing installation. Sorry I can’t provide direct support for docker issues!

Do you have any other way to install QIIME 2 natively? That is the only immediate workaround I can think of.

Once you do get this plugin installed and working I would love to hear more from you: feedback on existing actions as well as other methods you would like to see in there. Thanks!

Correction — see this tutorial instead for installing plugins in a 2018.11 docker container:

1 Like

Hi @Nicholas_Bokulich, thanks for your quick reply! I appreciate the help, espcially around this time of year. I was excited to see this tutorial, but unfortunately I ran into the same error. In fact, when I tried it with q2-perc-norm, as in the example, I had the same problem. From the conda error report:

  FileNotFoundError: [Errno 2] No such file or directory: '/opt/conda/conda-meta/certifi-2018.8.24-py37_1.json'

`$ /opt/conda/bin/conda install -c cduvallet q2_perc_norm`

In that folder in the container opt/conda/conda-meta it looks like several files, including certifi-2018.8.24-py37_1.json are missing.

ls -l
??????????? ? ?    ?          ?            ? certifi-2018.8.24-py37_1.json

There was no difference with source activate qiime2-2018.11 either.

Any ideas?


Hey there @aphanotus - are you able to run these steps as root? I am wondering if permissions are the problem here. Another option is to specify a user and group to docker (e.g. -u $(id -u):$(id -g), although that might not work as expected on a Windows machine).

1 Like