Importing sequence files (.fna) files

Thanks Sir
Sorry to disturb again, I am in an emergency for my analysis.
Please help out
I am running the command qiime tools import \ --input-path qiime2-importing-tutorial/ combined_seqs.fna \ --output-path combined_seqs.qza --type ’ DeMultiplexedSequences’.
However i am facing command error
Please help me out

Hi @divyaprince321,
I’ve made this PM public as the answers may help other users in the future who might have the same inquiry.
Have you seen the importing tutorial yet? If not, this section on importing .fna files seems especiallly relevant to what you are trying to do, pay close attention to the --type parameter there compared to what you have here.

In the future, providing us with the actual error will also be necessary to troubleshoot further. Good luck!

Hope you are fine and doing good
However after all the hard work I am done with this command successfully.

Now while importing the data

I am running the command qiime tools import \ --input-path qiime2-importing-tutorial/ combined_seqs.fna \ --output-path combined_seqs.qza --type ’ DeMultiplexedSequences’.

However i am facing command error

Please help me out

Please help out

while importing the data

Hello Mam
Hope you are fine and doing good
Since I am running the command qiime tools import \ --input-path qiime2-importing-tutorial/ combined_seqs.fna \ --output-path combined_seqs.qza --type ’ Demultiplexed Sequences’.

However I am facing command error
One thing important to mention here, I have a combined_seqs.fna file (creating in qiime 1 using add_qiime_labels.py). I am trying to import that file.
Please help out

Hello Mam
While I posted my error many times on the QIIME2 forum but to no response. I am not getting any response from the team members. May be because of their busy schedule.
However to some cheers I tried each step and finally succeeded.
But unfortunately I am stuck at otu clustering step.
I ran the denovo otu command two time
first time i got plugin vsearch error
and in the second time I ran it by adding the --verbose flag ( it may be annoying to add this flag)
Again error but this time a long error saying can not allocate memory.
I think I might be out of memory besides allocating 10.2gb memory on vbox.
Now my final request is I need a relative abundance table of the otus and the representative sequence file.
If I will run closed reference command
Will I get these two files
Secondly which file I have to use as reference-sequences in case of picking closed reference otus.
thanks Mam and Sorry for disturbance

That is correct. You can search the forum archive to see how others have addressed this same error. Unfortunately, allocating more memory to the virtual box and using a more powerful computer may be your only options.

The help documentation for all QIIME 2 actions details the outputs and their content. E.g., for this action type this into the terminal and hit enter:

qiime vsearch cluster-features-closed-reference --help

Among other details, you will see this:

Outputs:
  --o-clustered-table ARTIFACT FeatureTable[Frequency]
                          The table following clustering of features.
                                                                    [required]
  --o-clustered-sequences ARTIFACT FeatureData[Sequence]
                          The sequences representing clustered features,
                          relabeled by the reference IDs.           [required]
  --o-unmatched-sequences ARTIFACT FeatureData[Sequence]
                          The sequences which failed to match any reference
                          sequences. This output maps to vsearch's
                          --notmatched parameter.                   [required]

Your reference sequences of choice, imported as a FeatureData[Sequence] artifact. The data resources at qiime2.org contain several pre-formatted examples.

Good luck!

1 Like