Importing multiplexed paired end fastq data with barcodes in separate file as text format

import

(sreesankar) #1

Hi I am new to qiime2,
I am analyzing two data sets one having multiplexed data with bar-codes and primers and other data set have only primers multiplexed. In both cases my bar-code files are in a separate file having a text format. Both data set are from different sequencing companies.
I have gone through the Atacama tutorial for paired end analysis. In the tutorial for creating emp-paired-end-sequences.qza we require the following files forward reads, reverse reads and barcode.fastq files. Since my bar-codes are in text format, is there anyway to create a barcode.fastq.gz file with quality information, like the barcode.fastq.gz file mentioned in the tutorial.
Another query is regarding the metadata provided in the tutorial. For the barcode sequence section only single bar-code is given. I have two bar-codes and primer sequences both for forward and reverse. So this particluar format is not mentioned in the metadata.
I also tried the manifest format mentioned in importing dataset where we can use only multiplexed data. cutadapt was used to de-multiplex the data. After running the command line recieved the following error: blank space before +.
Finally query is that, the Atacama tutorial was ran in centos, which is a headless server. So I cannot view the .qzv files. So I copied the files in a local windows machine and tried to view in the chrome browser in the website view.qiime2.org/ again showed error message Error: Corrupted zip or bug: expected 40 records in central dir, got 0. So I ran the tutorial in the virtual box which worked fine. Since the virtual box is making my system hang I want to use qiime2 in the server. is there anyway to resolve the qzv file error.
Sorry for such a long post. I have gone through lot of qiime forums but I couldn’t find the specific topic related to my issues that is why I have created this post .


(Nicholas Bokulich) #2

(Chris Keefe) #3

Welcome aboard, @sree!
Some of these questions (e.g. your view.qiime2.org errors) likely belong in separate posts. We’ll discuss your first question here. Please open separate topics for every unrelated question.

I’m having some trouble understanding your situation. Please take a look at your data, and determine whether the suggestions in these posts (1, 2) apply to what you have. If not, please share sample data help us understand what you are working with. The filename and the first few lines of the file should do it.

NOTE: questions about how to perform analyses should be filed in General Discussion, not User Support. Please take a look at November’s Changes to the Forum before you re-post your other questions, as different categories may apply to each.

Thanks!
Chris


(Nicholas Bokulich) #4

(sreesankar) #5

Hi Chris,
Thank you for the reply. I have now de-multiplexed the barcodes and primers from the fastq files using cutadapt. Then I used manifest format to create the QZA artifact. After that in the Atacama tutorial for paired end analysis I have to do Demux for that the following options should be given:
–m-barcodes-file sample-metadata.tsv
–m-barcodes-column BarcodeSequence
Since I have already demultiplexed the data should I leave my BarcodeSequence and LinkerPrimerSequence blank or can I skip this step
Another query was regarding the visualization of the QZV file. I am using a cent OS based server which is a headless server. So I can’t view the files there. So files were copied to my windows client machine and from there files were dragged to website view.qiime2.org/. When I did this I got the error which I have mentioned in the post previously. So I have installed the QIIME2 virtual box, in which the QZV file generated works fine with the same tutorial dataset I have used.


(Nicholas Bokulich) #7

(Chris Keefe) #8

@Sree, if your data is demuxed, you can skip demultiplexing

As requested above, please post this as a new topic.


(Nicholas Bokulich) #9

(sreesankar) #10

Hi Chris,
Thank you for the reply. But for the next step I need to denoise my data for that I need to view my data through QZV artifact. could you please tell me if I don’t demux my data how can I get the QZV artifact is there any other way to view the quality of my data or I should use softwares like fast qc to know from which base pair I have to trim to achieve the Phred score of 33 or 64. I have just started using the qiime2 so I really apologize if I am mentioning something wrong in these steps.
I am really new to qiime and qiime forum. Should I post my second query to technical support or user support


(Chris Keefe) #11

(Chris Keefe) #12

@Sree, please use complete, specific commands whenever possible. This will make it much easier for mods and other forum users to understand exactly what you’re trying to do. Putting them in preformatted text format (ctrl-shift-c, or in the edit menu) will help keep your posts readable.

If I understand what you’re doing, you have already demultiplexed your data using qiime cutadapt demux-paired, which provided you with a .qza of the type SampleData[PairedEndSequencesWithQuality]. If you’re just looking for a way to visualize the quality scores of your demultiplexed data before denoising, try qiime demux summarize. That will produce a .qzv summary like this one, with an interactive quality plot that’s very useful.

:peace::heart: :bar_chart:
Chris


(Chris Keefe) #13

(Chris Keefe) #14

Take a look at the suggestions here and just use your best judgement. You’ll do fine! :+1:

-Chris


(sreesankar) #15

Hi chris,
I did not used qiime cutadapt demux-paired. That is I did not used the qiime cutadapt plugin present in qiime2. I have installed Cutadapt 1.18 separately using conda and used that one. Then I have used the manifest format to import my data to qiime2. Thank you for explaining how to visualize the quality of my data. I think if I have error messages I should report to technical support platform and if I have problem in performing analysis I should report to user support. Thank you for your time and patience.


(system) #16

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.