Importing Data on QIIME2

As adviced by thermokarst Matthew Ryan DillonLeader,
(qiime2-2017.12) [email protected]:~$ qiime tools import --type EMPPairedEndSequences – input-path home/qiime2/Desktop/EMPPairedEndSequences/barcoded.fastq.gz --output-path barcoded.fastq.qza
Usage: qiime tools import [OPTIONS]

Error: Missing option “–input-path”.

Should I use UCLUST or R?
Thank you for try QIIME2
Om Shanti
शान्ति

Kind Regards,
Antonio Silvestro

– input-path home/qiime2/Desktop/EMPPairedEndSequences/barcoded.fastq.gz --output-path barcoded.fastq.qza

try changing to:

qiime tools import \
    --type EMPPairedEndSequences \
    --input-path home/qiime2/Desktop/EMPPairedEndSequences/barcoded.fastq.gz \
    --output-path barcoded.qza

I think the code was just formatted incorrectly.

2 Likes

Thanks @Micro_Biologist!

I think so too - there was a space in the the --input-path flag above (e.g. -- input-path), which wouldn’t work as expected. @TonySilver, please give @Micro_Biologist’s suggestion a shot! Thanks! :t_rex:

Neither formatted as on advice of @Micro_Biologist the command flagged run…

Good afternoon,

Thanks for working through this with us. Can you post the command that did not run and the error it made?

Qiime commands are OK with dashes - but don’t like em-dashes . One of those dashes could confue qiime, and we could see if this is happening by looking at the command you ran.

Thanks for posting all these commands!
Colin

1 Like

@TonySilver — as @colinbrislawn said, we need you to provide the exact command run, as well as the complete error you saw when running that command. With that said, looking at the original command you posted above, I suspect the error you saw is because your import data doesn’t match the declared type of data. Specifically, you are importing type EMPPairedEndSequences, but you are providing only one input file (barcoded.fastq.gz). Please review the Importing Tutorial section on EMP Single-end and Paired-end data for more details on how to import these data.

In the future, please provide a summary of:

  • The version of QIIME 2 you are using
  • The exact command you ran
  • The exact error you observed
  • A little bit of summary and description text explaining what it is you are trying to do, that way we have some context.

As well, I highly recommend you review the Docs, and the Getting Started Guide, before jumping into running an analysis with your own data.

(qiime2-2017.12) [email protected]:~$ qiime tools import \

--type EMPPairedEndSequences \
--input-path home/qiime2/Desktop/EMPPairedEndSequences/barcoded.fastq.gz \
--output-path barcoded.qza

Usage: qiime tools import [OPTIONS]

Error: Invalid value for “–input-path”: Path “home/qiime2/Desktop/EMPPairedEndSequences/barcoded.fastq.gz” does not exist.

The typed in the command are en-dashes, neither em-dasher nor hyphen.

Hi @TonySilver,

This is a new error - you are seeing this because you were able to fix up the space/dash issue from earlier. The new error is:

This is a general warning that the file home/qiime2/Desktop/EMPPairedEndSequences/barcoded.fastq.gz doesn’t exist. To fix the immediate issue, you will need to update that path to reflect a file that does actually exist. Remember, filenames are case sensitive. Once you get the path to the file fixed, you will run into another error that I discussed above, because this command is semantically invalid (you are trying to import data in a way that doesn’t make sense to QIIME 2).

I strongly suggest that you take a step back and work through the resources I linked to above, instead of focusing on your own data - there appear to be several preventable mistakes happening here that can probably be avoided if you take a little bit of extra time to review the resources we have made available to you. The tutorials have been designed to be straightforward for new users to get familiar with QIIME 2 in a timely and efficient manner.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.