"Illegal instruction error" when I use qiime --help

Hi, everyone

I really wanna use QIIME2, So I followed the installing QIIME2

  1. install Miniconda3 & conda updata conda / conda install wget - successfully
  2. Install QIIME 2 whithn a conda enviroment - wget https://data.qiime2.org/distro/core/qiime2-2017.12-py35-linux-conda.yml
  3. conda env create -n qiime2-2017.12 --file qiime2-2017.12-py35-linux-conda.yml
  4. source activate qiime2-2017.12 - Success

remove & reinstall 2 times.. but I got same error message TT

After that, I use qiime --help TT

I got the error Message " QIIME is caching your current deployment for improved performance. This may take a few moments and should only happen once per deployment."
Illegal instruction

What do I solve this problem? Plz Help me !!

Hi @JoeyKim! What operating system are you trying to install on? The terminal screenshot looks a lot like a Windows shell, but your install log indicates that you were performing a linux installation. Thanks! :t_rex:

Hi @thermokarst Thank you for giving answer.

I just trying to install QIIME2. and I use Putty Program, cuz My server is far from here.

I use Centos 6.5(Linux), and I already use QIIME1 successfuly TT

Plz help me I don’t know What do I have to do…

Hi @JoeyKim, thanks for the info. I don’t know what is happening here, but usually an Illegal Instruction error means you are trying to run software on your system that is trying to use some optimizations that aren’t available to you (like processor optimizations, for example). This is a bit surprising to see this error, because running qiime --help doesn’t do anything fancy, it just loads python, does some quick checks, and then closes out. Are you able to run python on its own?

$ python --version

Also, can you provide the output to the following command:

$ conda info

I don’t use centos, so I can’t comment on the specific version (6.5), but it does seem to me to be a bit old. Anyway, after you send the info we requested above, we can brainstorm on a solution moving forward. Thanks!

Hi. @thermokarst, thanks for your answer.

I checked $python --verison - Python 3.5.4

and i can see the conda info TT

what’s wrong with me …

So, I would change my OS centos to other…

thank for your help!

Thanks for the info @JoeyKim — I am going to reproduce some steps here that @jairideout outlined for detailed diagnosis of this type of problem:

  1. Check if you have gdb installed by simply running gdb. If you receive an error stating “no such command”, you’ll need to install gdb. There’s instructions here, you may need your system administrator to install it for you depending on your user permissions.

  2. Once you have gdb installed, run:

    gdb -ex r --args python -c "import qiime2.sdk; qiime2.sdk.PluginManager();"

    This should hopefully reproduce the error you reported earlier, and then drop you into a gdb debugger session.

  3. From within the gdb interactive shell, run:

  4. Run the quit command to exit the gdb session.

Please send all of the output from steps 2 and 3 above (please copy and paste!).

Thanks! :t_rex:

1 Like

Thanks for the info @thermokarst

This is the output from steps 2 & 3

GNU gdb (GDB) Red Hat Enterprise Linux 7.6.1-100.el7
Copyright © 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and “show warranty” for details.
This GDB was configured as “x86_64-redhat-linux-gnu”.
For bug reporting instructions, please see:
Reading symbols from /root/miniconda3/envs/qiime2-2017.12/bin/python3.5…done.
Starting program: /root/miniconda3/envs/qiime2-2017.12/bin/python -c import\ qiime2.sdk;\ qiime2.sdk.PluginManager();
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib64/libthread_db.so.1”.
Detaching after fork from child process 10485.
[New Thread 0x7fffea516700 (LWP 10486)]
[New Thread 0x7fffe9d15700 (LWP 10487)]
[New Thread 0x7fffe7514700 (LWP 10488)]
[Thread 0x7fffe9d15700 (LWP 10487) exited]
[Thread 0x7fffe7514700 (LWP 10488) exited]
[Thread 0x7fffea516700 (LWP 10486) exited]
Detaching after fork from child process 10489.
Detaching after fork from child process 10491.
[Inferior 1 (process 10481) exited normally]
Missing separate debuginfos, use: debuginfo-install glibc-2.17-196.el7_4.2.x86_64 libuuid-2.23.2-16.el7.x86_64 openssl-libs-1.0.2k-8.el7.x86_64
(gdb) bt
No stack.


I changed My OS centos 6.5 to centos 7.0 .

After that, I didn’t get the illegal message but I also get this

QIIME 2 command-line interface (q2cli)

To get help with QIIME 2, visit https://qiime2.org.

To enable tab completion in Bash, run the following command or add it to
your .bashrc/.bash_profile:

  source tab-qiime

To enable tab completion in ZSH, run the following commands or add them to
your .zshrc:

  autoload bashcompinit && bashcompinit && source tab-qiime

–version Show the version and exit.
–help Show this message and exit.


So, I follow the command “source tab-qiime” -> success

but, I can’t use this “autoload bashcompinit && bashcompinit && source tab-qiime”

Do I have to add ZSH??

Looks like you are all good to go! You don’t need to install ZSH - ZSH is an alternative shell to Bash. If you have Bash, that is just fine. Time to start QIIMEing with your new deployment! Good luck and let us know if you have any questions (please open new topics for any new questions, thanks!) :t_rex:.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.