Ignore_missing_samples argument in q2-diversity

Dear QIIME developers,

I wonder if you could make this “ignore_missing_samples” argument available to the q2-diveristy plugin. There are previous questions on this issue related to the emperor plugin, which has been solved. But when using “qiime diversity core-metrics-phylogenetic”, this is still an issue. It might be just a simple fix.


Hi @wangj50,
Please see this topic for some explanation. It is still possible to use that parameter in emperor, but at the moment we are not planning to add that parameter to core-metrics.

Thanks Nick! I guess I’ll just run the command one by one. Or is it possible to add a flag to disable producing the visualization, so that we don’t have to face that problem.

Interesting proposal, but one that is not currently possible in QIIME 2.

For now you either need to run the commands one-by-one or just make sure that your sample metadata describes all samples found in your feature table (even if those samples just contain null values for all fields). After all, dropping samples missing in the metadata is all that flag does, and is something that should be easily addressed at the user end anyway:

  --p-ignore-missing-samples / --p-no-ignore-missing-samples
                                  This will suppress the error raised when the
                                  coordinates matrix contains samples that are
                                  not present in the metadata. Samples without
                                  metadata are included by setting all
                                  metadata values to: "This sample has no
                                  metadata". This flag is only applied if at
                                  least one sample is present in both the
                                  coordinates matrix and the metadata.
                                  [default: False]
1 Like