I can't install qiime2

debug.txt (182.2 KB)
The attachment appears when I run the conda env create -n qiime2-2023.7 --file qiime2-2023.7-py38-linux-conda.yml command in Ubuntu 22.04.3 LTS (GNU/Linux 6.2.0-32-generic x86_64) I don't know how to solve the error. Can anyone help me? My anaconda version is conda 22.9.0

1 Like

Hello @a17370910195,

Welcome to the forums! :qiime2:

In that file, I see this line:

curl: (18) transfer closed with 5372118 bytes remaining to read

It looks like that happens (stack overflow) when the network connection is cut off or disrupted for some reason.

Can you try running this again (or a few more times!) and seeing if the download is able to complete?

I tried again many times and it was still the same. I even changed the network environment.

Thanks for keeping me updated.

I overlooked an important detail!


This packages has it's own issue right now.

Your network may be fine, and only this package is causing a problem.

This forum member had success by removing their .condarc file. You could try that...

I found two ways to solve this problem, which I think can be provided as a reference for users in mainland China:

  1. Delete the bioconductor-genomeinfodbdata line in qiime2-2023.7-py38-linux-conda.yml and then reinstall this package separately in the created environment.

  2. Change the file dataURLs.json file in /root/anaconda3/share/bioconductor-data-packages/ and change the url of genomeinfodbdata to Tsinghua mirror source (TUNA)

1 Like

I reinstalled conda and deleted the .condarc file, but found that it had no effect. Then I reset my system and tried renting cloud servers in different countries but it still didn't work. The same error still occurs.

1 Like

An off-topic reply has been split into a new topic: trouble with qiime2 install

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.