How to trim and quality filter ion torrent data?


(Hidalgo) #1

Hey Nicholas and others,
I have been playing with the data and getting familiar with all the tutorials. Now I am going with me data all in.
Considering the demux graph (see picture below) I am planning to use trim-left 50 and trunc-len 300. You thing is accurate for this data?
Also I want to introduce another order to filter and select only the sequence with quality score >25, but I do not know how to do this although I read it somewhere…
Thanks for your help
Cheers


Qiime2 with IonTorrent data
(Matthew Ryan Dillon) #2

(Nicholas Bokulich) #3

trunc 300 makes sense. I’m not sure the trim is needed unless if this is to trim primer (I think the dada2 developer does recommend trimming 5’ for ion torrent data but you should check the dada2 docs for that advice).

you can use the trunc-q parameter

good luck!


(Nicholas Bokulich) #4

(Hidalgo) #5

Thanks for your help again. I have a new issue… when I was trim left and trunc-leng I was able to move forward smoothly as in the tutorial of “moving pictures” till the end obtaining OTUs from database SILVA, everything ok.
However when I went back and try to add the option trunc-q I get the following error:

Claudio$ qiime dada2 denoise-single --p-trim-left 0 --p-trunc-len 295 --p-trunc-q 25 --i-demultiplexed-seqs microbiome-demux.qza --o-representative-sequences rep-seqs3.qza --o-table microbiome-table3.qza --o-denoising-stats microbiome-stats3.qza

Plugin error from dada2:

An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

Debug info has been saved to /var/folders/9f/y7sk10pd2zb_dtw0f1jndp9m0000gn/T/qiime2-q2cli-err-aanougzt.log


(Nicholas Bokulich) #6

Please post the complete error message. This will be the contents of /var/folders/9f/y7sk10pd2zb_dtw0f1jndp9m0000gn/T/qiime2-q2cli-err-aanougzt.log, or else re-run the command with the --verbose flag.


(Nicholas Bokulich) #7

Chances are the trunc-q parameter is causing the reads to be trimmed too much. If manual trimming works for you, just proceed with that.