How to retain data while upgrading Qiime2 on virtual machine?

Hello,

Are there specific instructions on how to upgrade qiime2 on a virtual machine? This thread suggests to download and install the newest version of the virtual box. Does that mean I have to uninstall the current one? What happens to the data that is on it? I would like to keep all the files I have on the current virtual machine. Do I have to manually transfer the files to the new virtual machine?

Thanks in advance!

Hi @kmz!

Yes - follow the installation instructions on the QIIME 2 Docs: Installing QIIME 2 using VirtualBox — QIIME 2 2020.6.0 documentation

These instructions are prepared in a way that will allow you to install multiple versions of QIIME 2 VirtualBoxes concurrently.

No.

Nothing, unless you delete the VM.

Set up a shared-folder:

https://docs.qiime2.org/2020.6/install/virtual/virtualbox/#optional-shared-folders-and-copy-and-paste

Then, copy the files to your host OS.

Hope that helps! :qiime2:

1 Like

Thank you @thermokarst.

I tried the first step, i.e. installing the latest virtual box. I downloaded virtualbox 6.1.12 and installed it.
I was afraid that I was making a mistake. So I tried to open the older virtual box, but I couldn’t find it! Should I not have installed a new virtual box? Have I lost the data that was on the older virtual machine?!! :frowning: If yes, is there anyway I can get it back! Please let me know!

Thanks!

In addition, I opened the new virtualbox. It had my old Qiime2 core on it. I tried to open it and got this error message:
Failed to open a session for the virtual machine QIIME 2 Core - 2018.11 (1542146018) .

Failed to load R0 module D:/VMMR0.r0: The path is not clean of leading double slashes: ‘D:/VMMR0.r0’ (VERR_SUPLIB_PATH_NOT_CLEAN).

Failed to load VMMR0.r0 (VERR_SUPLIB_PATH_NOT_CLEAN).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I would appreciate any help to get my data back!
Thanks!

I apologize for the multiple posts. I did some digging and found this forum where someone just uninstalled the virtual machine and reinstalled it. Will this work for me. I ask before trying because I hope that my data can still be recovered, and don’t want to do anything to jeopardize that chance.

1 Like

Hi @kmz.

Hmm, I don’t know what to tell you — did you run an OS search for the VM?

I’m not sure, we aren’t the developers of VirtualBox, I’m not too sure what happened, or why.

I just ran a quick google search and saw this, can you try the suggestions here?

Keep us posted.

1 Like

Thanks @thermokarst. I uninstalled the Virtual machine and re-installed it and now it works. The data was stored on the virtual disk image of qiime2, so I have all my data now (phew!). I think there were a few issues that caused the problem:

  1. I had not uninstalled the older virtual machine. Apparently when going from version 5 to version 6 of the virtual box, (as opposed to going within releases of version 6) this creates a problem.
  2. I had installed the virtual machine directly in the root folder (this had worked for fine the virtual machine version 5), which the version 6 does not like.

I addressed both these issues after uninstalling the virtual machine, and things were fine.

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.