Have cutadapt bug fixed?

Hi everyone,
Just for ask, have the bug highlighted in this thread Cutadapt thinks my fastq.gz files aren't fastq.gz been solved? I met a same bug
missing sequence for record beginning on line 5
, and trim the primer one-by-one seems a little annoying because I have 30*2(illumina paired) files… Thanks!


Hi there @wym199633, unfortunately that bug hasn’t been fixed yet. You can try the workaround I posted further down in the thread you linked to. Please let us know if you get stuck or need assistance, we are here to help!

Good luck! :t_rex:

1 Like

For the paired-end reads, I did

cutadapt --front forwardprimer -m 1 SRRxxxxx_1.fastq.gz -o trimmed/SRRxxxxx_1.fastq.gz
cutadapt --adapter reverseprimer -m 1 SRRxxxxx_2.fastq.gz -o trimmed/SRRxxxxx_2.fastq.gz

Is this the right way to trimming primers off?


Hi @wym199633,

That’s close, but the --front and --adapter options have more to do with which end of the DNA you are operating on.

This section of the cutadapt docs helps explain it a bit better. The -g flag is also called --front and the -a flag is also called --adapter. So you’d want to use the -g flag with your forward primer on your forward read and also use a reverse-complemented reverse-primer with the -a flag on your forward read to drop the reverse primer (only needed if your amplicon is short enough that this is a concern, e.g. ITS).

Then on your reverse reads same deal, but now you are using the normal reverse primer with -g and the reverse complemented forward primer with -a.

Basically you are always going to use --front even on your reverse reads, but you may also need --adapter if you might have sequenced over your reverse primer.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.