Getting multiple cores being used for dada2 denoise-paired

Ive tried the below denoise-paired script. Im running a 22 core system with 32g RAM. I undestand that this script takes some time by reading previous threads, however i’d like to know if i have to initiate these cores manually on my PC?

i tried the $top command and got this:

Tasks: 2104 total, 3 running, 2100 sleeping, 1 stopped, 0 zombie
%Cpu(s): 1.4 us, 0.2 sy, 0.0 ni, 98.4 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem : 52826492+total, 11241284 free, 16626651+used, 35075712+buff/cache
**KiB Swap: 53676441+total, 53385971+free, 2904692 used. 35834044+avail Mem **

175234 codea 20 0 4218460 3.778g 20228 R 99.7 0.7 52:12.08 R

qiime dada2 denoise-paired
–i-demultiplexed-seqs manifestout.qza
–o-table dada2-table.qzv
–o-representative-sequences dada2.qza
–o-denoising-stats stats.log
–p-trim-left-f 20 --p-trim-left-r 20
–p-trunc-len-f 250
–p-trunc-len-r 250

additionally, I’d like to know if the $–verbose parameter will work on my PC?

Thanks for your time.

Good morning,

You probably found this already, but I wanted to point you to the offocial documentation for the dada2 denoise-paired plugin.

You do! As you can see in the documentation, there is a --p-n-threads flag you can pass.

It should! Have you tried using it?

Let me know if that helps,

1 Like

Thanks for your help!

I tried the $-- verbose parameter to which it is showing a running log.

I also manually initiated the cores on the PC with the --p-n-threads parameter. Out of my 22 cores, i can see that it has used up to 10 at one time now, instead of just 1.

Thanks again.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.