Fungal ITS_trimming primers

I tried using to following command from the fungal ITS analysis tutorial to eliminate the read through issue:

qiime cutadapt trim-paired
--i-demultiplexed-sequences paired-end-demux.qza
--o-trimmed-sequences demux-trimmed.qza

but I am getting following error:

Plugin error from cutadapt:

/tmp/q2-CasavaOneEightSingleLanePerSampleDirFmt-ic7s89ib/sample-8_34_L001_R2_001.fastq.gz is not a(n) FastqGzFormat file:

Missing sequence for record beginning on line 9

Debug info has been saved to /tmp/qiime2-q2cli-err-vm7im9bm.log

But when I open the mentioned fastq file everything looks fine to me. I am attaching screenshot for your reference.

should I use cutadapt outside qiime environment and then re import the fastq files in qiime again?

I will be very thankful for any help regarding this matter.


I am not an expert on this, but I kind of recognized the problem. I had the same issue using ITSxpress. It turned out the error appeared when some of the reads were trimmed to length 0. Maybe this is causing a problem for you as well?


@einamart but line 9 looks fine to me…can you please check the image I have attached and let me know. Maybe I am missing out something here which you can pinpoint. Thank you.

can you please tell me the processing time of ITSxpress? I am using it for first time and don’t know the expected time period.

Yes, the untrimmed looks good. The problem could be that cutadapt doesn´t accept returning trimmed samples with no sequences. It was just a guess, hopefully someone else will add some information on this :slight_smile:

I can recommend ITSxpress. Have a look at the tutorial Q2-ITSxpress: A tutorial on a QIIME 2 plugin to trim ITS sequences. 2 samples take about 3 minutes, so it takes some time. I ran it by night. However, DADA2 went much faster.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.