Filter OTUs using OTU ID failed

Hello,

I am trying to use OTUs ID to filter out OTUs from the feature-table. I’ve checked and followed this post [Filter OTUs from features table using OTU IDs?], but only some OTUs were removed from the list.

I am using QIIME2.2019.1
Here is what I ran:
qiime feature-table filter-samples
–i-table feature-table.qza
–m-metadata-file OTUs_ID.tsv
–p-exclude-ids
–o-filtered-table Filtered-feature-table.qza \

My OTUs_ID file is like

#OTU ID
06bfd6608071f821cad7a145527bf0cb
b264ac8ff5f9aff74f0b9aa084d9a9f0
e7b747477b38f49f5be074a19b9416a0
bbae6ed124f4d6b48435a964a95c8418

I have around 267 OTUs to remove, and output only removed 85 OTUs. Is the OTUs read number matter? There are some OTUs have high read number. If the read number doesn’t matter, is there a way to troubleshoot this? Or any other suggestion?

Thank you.
SY

Interesting puzzle, @SY_Yang!
Are you trying to filter out the samples that contain those OTUs, or actually trying to filter out the features themselves?

You may want to look at the qiime feature-table filter-features command instead of filter-samples.

Good luck!
Chris

Dear @ChrisKeefe,

Thank you!!! It works perfectly!!! All the features has been removed!

About the 85 OTUs that has been filtered first, those are the OTUs only in one sample that I removed earlier. I think they just got removed when I ran the filter-samples with OTUs ID, and their values were zero.

Have a great day!
SY

1 Like