Filter-features without removing samples with zero counts from the output for posterior taxa-plots

Hi everybody

I had to create a new topic with my question because the last topic with similar characteristics was closed (“Feature-table filter-features keep samples for heatmap”). After I filter my samples from features with less than 2 counts the script that I used removes automatically samples with zero counts. However, for the taxa plot, I need these samples to show the differences between different extraction methods used in my experiments. From the previous topic, @Nicholas_Bokulich generated a request to update this function and have the option to choose whether the samples with zero counts were removed or not ( I would like to know if that was implemented or not because I have look and I don’t seem to find anything like this. Is there any other function that would allow this?.

This is the script I am using:

qiime feature-table filter-features
–i-table samples.qza
–p-min-frequency 2
–o-filtered-table samples_2FreqFilter.qza

Thank you!


Hi @Vilma_Perez,
That issue remains open and up for grabs. This is not yet implemented in q2-feature-table.

For the time being, the only other solution would be to export these data to plot outside of QIIME 2.

Good luck!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.