feature-table summarize [solved]

Hello,

I'm using qiime2-2021.4 through conda, running on ubuntu 16.04.7 LTS. My system has 4 cores and 32GB of RAM.

I am trying to run the following command to visualize my delbur outputs .qza as a .qzv artifact :

qiime feature-table summarize --i-table deblur_output/table.qza --o-visualization deblur_output/deblur_table_summary.qzv

I have run this line successfully on a different dataset in qiime2-2020.2. This time however, it keeps running indefinitely and never outputs a .qzv file. Moreover, the command does not print any stacktrace/logs, even with the --verbose option, making it difficult for me to diagnose what is going on. I am processing 309 samples.

I have had a look in the forum (e.g. here) and elsewhere online but haven't found a solution.

Any help would be much appreciated. Thanks in advance!

I ran the command in qiime2-2020.2 and it worked - it only took 2 minutes to run.

Still not sure why it would not work in qiime2-2021.4, perhaps this may help to diagnose the issue.

:slight_smile:

1 Like

Thanks for posting an update, @aisha_aug!

I'm not sure what was the cause of that - I just reviewed the code for that visualization and there were no changes to it between 2021.2 and 2021.4. I know this is a silly question, but I've done this before: did you forget to hit "Enter" after writing the command?

Have you tried again in 2021.4? Are you still seeing this?

Thanks!

Hey @thermokarst

Thank you for replying. Oh, i used 2020.2 not 2021.2, were there any changes between 2020.2 and 2021.4?

No worries, but I definitely hit enter. And yeah, I tried multiple times in 2021.4 to no avail.

1 Like

Oh sorry, my mistake, I totally misread that - yeah there were a bunch of changes between 2020.2 and 2021.2!

I kinda figured, thanks for confirming - like I said, I've made that mistake too many times...

Hmm, yeah we rebuilt the demux summarize viz halfway through 2020 to include some new sample counts and some other useful tidbits.

What kind of runtimes have you experience here? Hours? Days?

No worries !

I left it to run overnight, approximately 9 hours. When I woke up and saw it was still running I killed it. Then i tried again and left it for a few hours each time, then killed it.

1 Like

Wow, that is crazy - you're more patient than me. I'll put this on the TODO list to take a closer look at the more recent changes to that viz to see if there are any obvious issues there. Thanks for the info and the bug report!

:qiime2: :t_rex:

1 Like