Feature table summarize NaN error

Hi there,

I hope this is a trivial question, but haven’t found a way around it by myself …

I’m trying to filter my feature table to get a table that contains only the negative control samples, and then summarize the resulting controls table so I can view it. The commands I am using are:

qiime feature-table filter-samples --i-table final_with_healthy_noC_table.qza --m-metadata-file map_Matilda_2017.txt --p-where "Control='Y'" --o-filtered-table final_with_healthy_noC_controls_table.qza 

qiime feature-table summarize --i-table final_with_healthy_noC_controls_table.qza --o-visualization final_with_healthy_noC_controls_table.qzv

The first command to filter the table runs fine, but then the summarize command returns an error:

Plugin error from feature-table: cannot convert float NaN to integer

I have noticed other users have found a similar error using gneiss when there are zeroes, but not in feature-table before.

I have checked my mapping file for zeroes and blank cells and there aren’t any.

Next I tried to export the feature table created with filter-samples using qiime tools export, so I could try to see where the NaN values were. This worked, but when I tried to convert the output BIOM file to TSV to look at it, I got another error:

biom convert -i final_with_healthy_noC_controls_table/feature-table.biom -o final_with_healthy_noC_controls_table/feature-table.txt --to-tsv

Error: biom.exception.TableException: Cannot delimit self if I don't have data...

What else can I try? Thank you!

PS I am using version 2017.12 because I already did the bulk of my analysis for this project in that version and thought it would be best to keep it consistent …

Actually, I’m really sorry, I just worked out something really obvious that was causing this error. Can the staff please delete this thread?

Thank you!

Hi @Matilda_H-D! I suspect you were filtering out all of your samples in your filter command, which in turn wrote out a completely empty feature table (if there are no samples, then there are no features either!). When you exported and tried to convert using biom, well, you had an empty biom table, which it wasn’t happy about, in fact the error says as much (Cannot delimit self if I don't have data...). So, if you are able to track down what is happening with your filter step, you should be set. Thanks! :t_rex:

PS - we have an open issue for fixing up this vague error message.

Hi everyone,

Just to follow up – I made a pretty silly error but in case anyone else ever has a similar absent-minded moment and does the same, hopefully this post will help.

With my command, I was actually trying to filter out samples that had already been removed from the table I was using. That is, there were no samples that matched “Control=Y”, so the output of feature-table filter-samples contained no samples, and couldn’t be visualised because there was nothing in it. As @thermokarst explained, this meant the exported biom table also contained no samples, which was the source of the conversion error.

The lesson is don’t try to use Qiime when you haven’t had enough sleep :upside_down_face:


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.