Feature-classifier classify-sklearn; Error Segmentation fault (core dumped)

Hi,

I am using the following command to classify sequences uses a trained reference file from the qiime2 website:

qiime feature-classifier classify-sklearn
–i-classifier silva-132-99-515-806-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza

I have tried this command on two computers now. When I first ran the command, on both computers, I initially got an error indicating that I ran out of space in my temporary directory, so I created a new temporary directory and changed the temporary environment variable. This was confirmed after running the following:

env

However, after I change where temporary files should be saved, and rerunning the original command, I get a new error saying “Segmentation fault (core dumped).” I was using a computer with 8G of RAM, but then switched to one with 32G of RAM. The same error continues to occur.

Any help would be appreciated. Thanks!

Hey there @emmo1!

Just to make this clear, this means a partition on your hard disk is running out of space.

RAM (memory) is not disk space, but rather random-access memory space. Perhaps you are seeing this segfault because the location you mapped to is a ramdisk?

Can you provide some details about the disks, partitioning, and where you mapped tmp to?

Thanks! :qiime2:

Hey @thermokarst,

My working directory was

“/mnt/e/qiime/”

and I created a new temporary and saved to qiime2 environment using:

mkdir /mnt/e/new_temp
export TMPDIR=’/mnt/e/new_temp’

The ‘E:’ drive has 205G free after using

df -h

I think the issue was with the Windows linux subsystem, which until this moment has not had any problems handling linux programs. However, I used a Mac OS device recently and have successfully classified the features in my samples. Therefore, you can disregard this issue. I appreciate the quick response :slight_smile:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.