Facing Problem in updating 2020.11

@thermokarst,sir when i update my qiime 2020.8 into qiime 2020.11, it showed the following error could you please help me? how to rectify this error?

i also find this errors.


You may want to avoid "updating" a :qiime2: environment. It's best to simply create a new separate environment. For example, I typically keep the last 4 or 5 versions of :qiime2: as separate environments on my computer.




Thank you @SoilRotifer for your response, but can you please tell me how can I create separate environment for each qiime 2? actually i am running the command conda clean --all, and after that i run conda install wget then
wget https://data.qiime2.org/distro/core/qiime2-2020.11-py36-osx-conda.yml
conda env create -n qiime2-2020.11 --file qiime2-2020.11-py36-osx-conda.yml


rm qiime2-2020.11-py36-osx-conda.yml
after running these commands, I have activated the Qiime2-2020.11 by running conda activate qiime2-2020.11 and I got the same error that i mentioned earlier in this thread, so you are saying that please create a separate environment but i don’t know how to create a separate environment…


Shell issue

I just realized that I had not noticed the following line in your error log:
complete:13: command not found: compdef

Apparently this is a zsh chell issue. I have not used zsh. I am currently still using bash. I think if you running the following command may help:

autoload -Uz zsh-newuser-install && zsh-newuser-install -f

I got the idea from this source, which also provides other options.

QIIME 2 install

The commands you rand below are exactly how you create a new environment:

Were you ran these commands were you in the (base) environment? From the first screen shot it looks like you did everything as you were supposed to, i.e. running the command from (base).

Have you run conda update conda (within (base) prior to running the above commands? Perhaps uninstall the new qiime2-2020.11 env, update conda, re-install qiime. Not sure what else to do if this does not work.

That being said I think this is a shell issue.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.