extremely low "merged" score after using DADA2

Hello, I'm very new to Qiime2 and I've been having constant problems with the merged percentage in using DADA2 on my 16S data. (I have experienced no problems with my 18S results). I'm going to try and list everything I've tried so far, and maybe someone could help, it would be much apreciated!

  • Primers used: 341F- CCTAYGGGRBGCASCAG
    806R- GGACTACNNGGGTATCTAAT

  • Command used: qiime dada2 denoise-paired --p-n-threads 8 --i-demultiplexed-seqs p02_primer_trimmed.qza --p-trunc-len-f 231 --p-trunc-len-r 162 --output-dir DADA2_denoising_output --verbose > out.log

I already changed my tunc length several times all with very similar results

  • other trunc lengths I already used: f231 r186 / f210 r184 / f210 r173 / f231 r162;

  • My primers are trimmed

  • I'm going to try and upload my quality score and denoising stats

I have seen other Topics very similar to mine, but never with such low numbers, I'm not sure how I could proceed now. As mentioned, I'm very new to this, so I'm sorry if I'm not grasping something here. Thanks in advance for any hep

p02_primer_trimmed.qzv (295.4 KB)

denoising_stats.qzv (1.2 MB)

Hi @Mandy,
Thanks for providing your output files and commands, they are certainly helpful!
From looking at your dada2 result summary table it looks as though almost all of your reads are failing to merge, this is because your reads do not overlap based on your truncating parameters. This topic has been extensively covered in the forum, please have another through, keeping an eye out on keywords like dada2, overlap, merging etc.
One example is here or here, keep in mind min overlap for merging is now 12 nts (not 20). Have a read through those and see if you can figure out optimum truncating parameters and let us know if you are still having issues.
Good luck!

1 Like

Hi, thank you for your immediate reply!
I’m sorry I should have also mentioned that I used the following to calculate my overlap: 806-341 = 465, 2x300 – 465 = 135, (300-231) + (300-186) = 183

  • So I realised that these numbers were not sufficent for the needed overlap, but I already took these trunc- length numbers from the lowest quality score I was willing to take, and that’s why I’m not sure on how to continue. I have seen people using only their forward reads with Dada so I should have asked in my first post if that is an adequate option seeing as I’d loose reads…?
    And if so, how would a command look to leave out the reverse reads?

thank you kindly for your help, cheers

1 Like

Hi @Mandy,

Thanks for the additional info. Sounds like you figured out the source of the problem which is you simply don’t have enough of an overlap with your current truncating parameters. As for how to deal with this issue you have a couple of options

  1. If the goal is to use paired-end reads downstream, you need to relax your truncating parameters to allow for merging. Having looked at your quality plots I think the numbers you are picking are quite conservative. As you calculated, you have 135 bp overlap region, taking into account the required minimum 12nt for merging, plus a little extra for natural length variation of V3-V4 region, you have a combined ~ 100 nt that you should be able to safely truncate from your reads. Try something like truncate 270 from your Forwards and 230 from your Reverse reads and see how this works. You may have to fine-tune this to maximize how many reads pass the initial filtering (which increases as you truncate more from the reads).
  1. Use forward reads only. This will always retain more reads than any combination of paired-end you try, but you do lose a little resolution because you will be using shorter fragments. I will mention however that the resolution you lose from say 250 nts reads vs 450 ones is not as great as you may think. So this is not a bad option by any means.

Just use the dada2 denoise single action and it will just ignore your reverse reads.

Hope this helps!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.