Error with single-end demultiplexing: missing samples in output demux.qza


I’m hoping to get some help with a recurring error with a q2-demux emp-single script I am trying to run.

I have multiplexed 16S single-end reads from an Illumina HiSeq run. After I successfully run qiime tools import for EMPSingleEndSequences and get an output (single_end_sequences.qza), I run the following script:

qiime demux emp-single
–i-seqs single_end_sequences.qza
–m-barcodes-file metadata.tsv
–m-barcodes-column BarcodeSequence
–o-per-sample-sequences demux.qza
–o-error-correction-details demux-details.qza

The script runs successfully, but in the output demux.qza file, I end up missing ~200 samples from my metadata file.

I’m not sure what the problem is, and if it is some sort of indexing issue I may be facing.

One thing I wonder is if it has anything to do with my need to include the --p-no-golay-error-correction parameter. Without this parameter, my script results in the following error:

“Golay decoding requires 12nt barcodes. The barcode attempting to be decoded (TTTGCATTTTA) is of length 11nt.”

We use 12nt IDT primers, so I’m not sure why the script using default golay parameters results in this error. I’m wondering if this points to an indexing issue and the reason for my lost samples.

Any feedback would be appreciated!

Hi @kchadaideh,
Welcome to the forum!
Can you clarify a couple of things from your set up please.

  • Are you sure design is exactly based on the EMP protocol? This plugin is really assuming that it is.
  • Do you have single barcodes only on your 5’ or is this dual barcoded and you have barcodes on the 3’ as well?
  • Are your barcodes Golay decoding? The error you are seeing is caused by the fact that in your BarcodeSequence barcode column, in at least one instance (TTTGCATTTTA), there is a 11 nt sequence but the EMP Golay correction expects 12 nt barcodes. Can you check your barcode sequences and see what their length is?

Overall if it turns you do not have a EMP protocol set up then you may want to check out the q2-cutadapt plugin which gives you a lot more flexibility with regards to demuxing non-EMP set ups.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.