Error while using feature-classifier fit-classifier-naive-bayes

I was using the function feature-classifier fit-classifier-naive-bayes for SILVA132 version in QIIME2-2019-7 version installed using conda.

I ran the command and got the error-
qiime feature-classifier fit-classifier-naive-bayes --i-reference-reads silva_99_341F806R.seqs.qza --i-reference-taxonomy silva_99_consensus_taxonomy.qza --o-classifier silva_99_341F806R_classifier.qza --verbose &> silva_99_341F806R_classifier.log

/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/q2_feature_classifier/ UserWarning: The TaxonomicClassifier artifact that results from this method was trained using scikit-learn version 0.21.2. It cannot be used with other versions of scikit-learn. (While the classifier may complete successfully, the results will be unreliable.)
warnings.warn(warning, UserWarning)
Traceback (most recent call last):
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/q2cli/”, line 327, in call
results = action(**arguments)
File “</mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/>”, line 2, in fit_classifier_naive_bayes
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/qiime2/sdk/”, line 240, in bound_callable
output_types, provenance)
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/qiime2/sdk/”, line 411, in callable_executor
spec.qiime_type, output_view, spec.view_type, prov)
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/qiime2/sdk/”, line 267, in _from_view
result = transformation(view, validate_level)
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/qiime2/core/”, line 70, in transformation
new_view = transformer(view)
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/site-packages/q2_feature_classifier/”, line 86, in _2
tar.add(fn, os.path.basename(fn))
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/”, line 1952, in add
self.addfile(tarinfo, f)
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/”, line 1980, in addfile
copyfileobj(fileobj, self.fileobj, tarinfo.size, bufsize=bufsize)
File “/mibi/users/jsb562/miniconda2/envs/qiime2-2019.7/lib/python3.6/”, line 252, in copyfileobj
OSError: [Errno 122] Disk quota exceeded

Plugin error from feature-classifier:

[Errno 122] Disk quota exceeded

See above for debug info.

I was running the above command on HPC with 64 cores and 1TB ram. Any suggestions?

PS: I used the same command in the older version of QIIME2 (2018-11), and it worked there, but once I updated the QIIME2 (2019-7) it is showing an error.

The disk quote exceeded may not be your home directory (which is what I assume has the 1 TB disk space you quote), but rather the temporary directory. You may want to get in touch with the HPC admin to see if you can set a different temp directory, and/or why you do not have enough space in your home directory (or whatever destination you set for your output artifact).

Probably because your disk space (or temp space) has filled up between then and now. Or are you able to successfully run 2018.11 now?

1 Like

Thank you for the information. I will talk to HPC admin about this.

Yes! I am able to run qiime2 2018.11.

1 Like