Error when running qiime quality-control evaluate-seqs


I did the alignment using Vsearch and observed taxonomy, built phylogeny and everything worked great. I wanted to view the summary of the alignment results (number of hits, mismatches etc) and I tried running the qiime quality-control evaluate seqs using the following commands:

qiime quality-control evaluate-seqs \

–i-query-sequences analysis/rep-seqs.qza
–i-reference-sequences phylogeny/99_otus.qza
–o-visualization qualitycheck

But after running for several hours, an error popped up:

Plugin error from quality-control:

Image size of 15233x697000 pixels is too large. It must be less than 2^16 in each direction.

Debug info has been saved to /tmp/qiime2-q2cli-err-r67a4tta.log

Is there any other way to view the alignment result?


Hi @Shruthi,
The –p-show-alignments parameter is causing the slowdown as well as the error (you have so many sequences that they can’t all be plotted! hence the error). So I recommend removing that parameter and everything should work fine.

If you do really want to view the alignments (I am not sure that makes sense if you have so many sequences), you can just download the results from the visualization that is produced. The alignment results may or may not be shown in that output — if not, you should just export your data and use vsearch on its own to generate this alignment report. That way you will get the alignments as a text file.