error using taxonomy.qza as metadata

I am using this command to "qiime metadata tabulate --m-input-file ./taxonomy.qza --o-visualization ./taxonomy.qzv" after Classifying sequence as per taxonomy and getting error

getting error using taxonomy.qza file

Please help to solve the issue.

Hi @Priyanka,

When I searched the forum for this issue I found that many other users have had this issue and resolved it. Please look through those previous posts and see if you can find a solution to your problem there. This user had a solution that may be helpful getting you started!

-Hannah

1 Like

I tried, in the same way as mentioned in previous post but still getting same error in my taxonomy.qza file

Hi @Priyanka,
How did you generate your taxonomy.qza?

If, its in qiime2 can you provide the command?

Can you run qiime tools validate on your artifact and provide the output of that?

Additionally, if you feel comfortable, would you please provide the taxonomy.qza so I could try to recreate this on my side?

Thanks!

1 Like

Hi,
I used qiime2 for taxonomy generation
Command used for it : "qiime feature-classifier classify-sklearn --i-classifier /home/bioinfo-premas/Documents/Priyanka/240131_M08920_0007_000000000-DN8CT/qiime2_analysis/V3-V4/V3-V4_classifier/silva138_AB_V3-V4_classifier.qza --i-reads rep-seqs-cr-0.97.qza --o-classification taxonomy.qza --p-n-jobs 8"

Please find taxonomy.qza here
taxonomy.qza (568.2 KB)

Thanks,
Priyanka

Dear Collins,

Thanks!!
It resolved by changing qiime version

1 Like