Error to install qiime2-2022.2 with conda

I am going to install the qiime2-2022.2 with conda on my mac, however, the same error happened for many times and can't be solved. Could you please do me a favor?
I succeeded in the installation of the miniconda and made some settings before install qiime2
(wget -O ~/; bash ~/ -b -p $HOME/miniconda; source ~/miniconda/bin/activate;
conda init zsh; conda update conda), these codes are working well.
And then I installed the qimme2-2022.2 using the codes "wget
conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml", and get the error "ERROR An error occurred while installing package 'bioconda::bioconductor-genomeinfodbdata-1.2.7-r41hdfd78af_1'. Rolling back transaction: done
class: LinkError
post-link script failed for package bioconda::bioconductor-genomeinfodbdata-1.2.7-r41hdfd78af_1
location of failed script: /Users/jiangkun/miniconda/envs/qiime2-2022.2/bin/ ..........(many lines)"
I realized the installation fail was caused by package 'bioconda::bioconductor-genomeinfodbdata-1.2.7-r41hdfd78af_1', so I download this package and installed locally (conda install ~/Downloads/bioconductor-genomeinfodbdata-1.2.7-r41hdfd78af_1.tar.bz2), however, I got the error same with above. Any answer or suggestions will be appreciated.
Kind regards,

Hi @yjk555,

Welcome to the :qiime2: forum!

From the error message you provided, it seems like there might be an issue with your conda environment(s) - can you run the following command for me and copy/paste the output in your response:

conda env list

Thanks! :lizard:

The output of "conda env list" are as follow:

conda env list

conda environments:

base * /Users/jiangkun/miniconda
qiime2-2022.2 /Users/jiangkun/miniconda/envs/qiime2-2022.2

Looking forward to your reply!
Jiangkun Yu

Hi @yjk555,

Thanks for sharing that! If you are working with a new mac that uses an M1 arm chip (thus requiring osx-arm64 builds), this forum post may provide a suitable workaround for you. Let us know if this doesn't resolve the issue! :lizard:

An off-topic reply has been split into a new topic: Error installing qiime2 2022.2 on linux

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.