Error running feature-classifier classify-consensus-vsearch

I am encountering this error: FileNotFoundError: [Errno 2] No such file or directory: '/data/folder1/TEMP_DIR/qiime2/root/data/049c20ce-179f-4034-aac9-155529c9a59b/provenance' despite confirming that this directory has all of the correct permissions (drwxrwxrwx.). The docker is mounted just fine with all the files present and I can't figure out where this problem is arising from. I would appreciate any help at all!

Hi @ajsacco,

Welcome to the :qiime2: forum!

Can you please post your full command and the output? A screenshot works if thats easier too!

-- Hannah

Hi @jphagen, here is the command I am running:

qiime feature-classifier classify-consensus-vsearch
--i-query rep-seqs.qza
--i-reference-reads silva_132_99_16S_sequence.qza
--i-reference-taxonomy silva_132_99_16S_taxonomy.qza
--p-perc-identity 0.85
--p-query-cov 0.8
--p-maxaccepts 100
--p-maxrejects 100
--p-maxhits 3
--p-strand 'both'
--p-unassignable-label 'Unassigned'
--p-threads 2
--o-classification vsearch_taxonomy.qza
--o-search-results vsearch_results.qza

I have tried running this code on my local computer, and within a docker image on a uss. Both have produced this same error so I don't think it's an issue with mounting and/or the directory format given that I have tried it in both of these scenarios.

I would appreciate any advice advice at all that you may have!

A screenshot of the error message is attached!

Hi @ajsacco,

One of the other moderators took a look at this error and thinks that it looks like one of your input artifacts might be missing the provenance subdirectory. Are you able to send the .qza files you used in your command to me so I can have a look? You can also send it to me via direct message, if thats better for you.


Hi Hannah,
I actually just reached the same conclusion! It looks like when you use qiime2 artifacts generated in an older version of qiime2, this is the error that appears. I noticed this when I tried running the script in a 2021 version, except the error explicitly said that the artifacts were made in a different version and stopped right away. I have since re-made the artifacts using the 2024.2 environment and it is working. Thanks you for help!


Awesome! I am so glad you were able to figure it out :slight_smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.