Error message while running qiime fragment-insertion sepp


(sreesankar) #1

Hi,
I am using the PICRUSt tutorial mentioned here https://github.com/picrust/picrust2/wiki/q2-picrust2-Tutorial.
For qiime fragment-insertion sepp command I had given my aligned-rep-seq.qza file and 99 otus aligned which I have downloaded from here: ftp://greengenes.microbio.me/greengenes_release/gg_13_5/gg_13_8_otus.tar.gz. I have imported this database using the commands mentioned here https://docs.qiime2.org/2018.11/tutorials/importing/, where I have used the import command for importing aligned sequences. This is the command line I have given in PICRUSt plugin for placing the ASV:

qiime fragment-insertion sepp --i-representative-sequences aligned-rep-seqs.qza
–p-threads 20 --i-reference-alignment 99_otus.qza
–i-reference-phylogeny rooted-tree.qza \
–output-dir tutorial_placed_out
I am getting the following error after I ran this command:
Parameter ‘representative_sequences’ received an argument of type FeatureData[AlignedSequence]. An argument of subtype FeatureData[Sequence] is required.

Following is the error log report:

Traceback (most recent call last):
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/q2cli/commands.py”, line 274, in call
results = action(**arguments)
File “”, line 2, in sepp
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 199, in bound_callable
self.signature.check_types(**user_input)
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/core/type/signature.py”, line 301, in check_types
name, kwargs[name].type, spec.qiime_type))
TypeError: Parameter ‘representative_sequences’ received an argument of type FeatureData[AlignedSequence]. An argument of subtype FeatureData[Sequence] is required.

Could you please help me to resolve this issue.
Regards
Sree


Picrust error
(Gavin Douglas) #2

Hi there,

The error means that the input sequences need to be unaligned - you are currently inputting sequences that are already aligned.

In addition, you need to place your study sequences into the reference tree / alignment specified in the tutorial otherwise you will run into downstream errors with q2-picrust2. In other words, the reference files you’re specifying are different from the reference files used by PICRUSt2. The commands to download the PICRUSt2 reference files are specified in the tutorial.

Best,

Gavin


(sreesankar) #3

I already finished the tutorial this is my own dataset. So can i use the reference files mentioned in the tutorial to my data, Even with unaligned data I am getting this error:
Parameter ‘reference_alignment’ received an argument of type FeatureData[Sequence]. An argument of subtype FeatureData[AlignedSequence] is required.


(sreesankar) #4

Hi,
I am having problem with PICRUSt. Based on the previous suggestions I have used the following commands:

qiime fragment-insertion sepp --i-representative-sequences rep-seqs.qza
–p-threads 20 --i-reference-alignment reference.fna.qza
–i-reference-phylogeny reference.tre.qza
–output-dir tutorial_placed_out

This worked fine. Now I am running the qiime picrust2 custom-tree-pipeline command. The following commands where used:

qiime picrust2 custom-tree-pipeline --i-table tutorial_placed_out/table.qza
–i-tree tutorial_placed_out/tree.qza
–output-dir q2-picrust2_output
–p-threads 25 --p-hsp-method pic
–p-max-nsti 2

While running this command, following error message came:
Error running this command:
hsp.py -i 16S -t /tmp/tmpslpe8dsa/placed_seqs.tre -p 1 -n -o /tmp/tmpslpe8dsa/picrust2_out/16S_predicted -m pic

Then the commands was re-ran using --verbose command this was the message:

File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/bin/hsp.py”, line 4, in
import(‘pkg_resources’).run_script(‘PICRUSt2==2.0.3b0’, ‘hsp.py’)
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/pkg_resources/init.py”, line 661, in run_script
self.require(requires)[0].run_script(script_name, ns)
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/pkg_resources/init.py”, line 1441, in run_script
exec(code, namespace, namespace)
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/PICRUSt2-2.0.3b0-py3.5.egg/EGG-INFO/scripts/hsp.py”, line 149, in
main()
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/PICRUSt2-2.0.3b0-py3.5.egg/EGG-INFO/scripts/hsp.py”, line 115, in main
check_files_exist([args.tree, trait_table])
File “/home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/PICRUSt2-2.0.3b0-py3.5.egg/picrust2/util.py”, line 326, in check_files_exist
raise ValueError("This input file was not found: " + missing_files[0])
ValueError: This input file was not found: /home/gene/sankar/miniconda3/envs/qiime2-2018.11/lib/python3.5/site-packages/PICRUSt2-2.0.3b0-py3.5.egg/default_files/prokaryotic/16S.txt.gz
Error running this command:
hsp.py -i 16S -t /tmp/tmp_qq5_hrr/placed_seqs.tre -p 1 -n -o /tmp/tmp_qq5_hrr/picrust2_out/16S_predicted -m pic

I understood the file 16S.txt gz is missing. Should I have to download this file separately? As PICRUSt installation was done without any errors I really couldn’t understand what is the actual problem?. Could you kindly help me to resolve this issue. If I have to post this as a new post kindly inform me.
Regards
Sree


(sreesankar) #5

Hi,
Please can anyone help me with this problem. I am really stuck at this point. I have read many qiime2 forums but was not able to find the solution.


(sreesankar) #6

Hi can you help me with this error. I have posted this error https://forum.qiime2.org/t/error-message-while-running-qiime-fragment-insertion-sepp/7838 in the qiime forum. I got a reply from Gavin Douglas. But nobody is replying my second error which I have posted in the same post as a second reply regarding another issue with same plugin. I am really stuck at this point.

Regards
Sree


(Matthew Ryan Dillon) #7

This error is for a different parameter than what you posted about above:

Your first error was about representative_sequences, while the second was about reference_alignment. Either way, @gmdouglas has given you some really valuable advise! Please double check that everything is in order on your end. Thanks.

PS - I made your DM public - we are not able to provide private support.


(sreesankar) #8

hi,
Thank you for the reply. yes both are different errors. first error i rectified. But the second error i could not figure out what is the actual problem. i need to resolve the second error, regarding the hsp.py. can you please give me some suggestions.

Regards
Sree


(Gavin Douglas) #9

Hi Sree,

If you installed PICRUSt2 with bioconda I think this problem will be resolved if you follow the instructions on the qiime2 library page instead: https://library.qiime2.org/plugins/q2-picrust2/13/

There is an issue with the bioconda installation currently which I’m working to resolve.

If you have already followed the instructions on the QIIME2 library page then I would recommend re-installing the tool and running “pytest” to test the installation after you have finished.

Best,

Gavin


(sreesankar) #10

Hi,
Thank you for the reply. I have installed Picrust as metioned in the qiime2 library page as mentioned above. Should I have to re-install based on installation procedure mentioned here https://library.qiime2.org/plugins/q2-picrust2/13/ ? or shall I use bioconda and install the Picrust in qiime2-2018.11 environment? If I did like that will the qiime files work with Picrust2?

Regards
Sree


(sreesankar) #11

Hi Gavin,
This was the test results. I think everything looks good. I will re-ran my commands and update you.

tests/test_hsp.py … [ 20%]
tests/test_metagenome_pipeline.py … [ 47%]
tests/test_run_minpath.py … [ 55%]
tests/test_util.py … [100%]

============================================================================== 40 passed in 45.03 seconds

Regards
Sree


(sreesankar) #12

Hi Gavin,
Thank you for the suggestions. After reinstalling it worked.
Regards
Sree