Error message after using ReSCRIPT for filtering for homopolymers


This is in relation to using Rescript to trim clustered sequences for homopolymers:

I used cull-seqs to get rid of homopolymers after clustering and filtering for chimeras. But I got this error message when taking that .qza file and trying to test the classifier to create a taxonomy.qza file :
(1/1) Invalid value for '--i-reads': '/local1/workdir1/tw488/CIDA_Sequencing_ Runs/ITS_RUNS1_6_allinoneCOPY/Trimmomaticoutput/Pair_usethis/uchime-dn- out/rep-seqs-nonchimeric-wo-borderline-homopolyless.qza' is not a QIIME 2 Artifact (.qza)

I tried filtering for homopolymers before filtering for chimeras, and got the same error message when trying to move on to the chimera filtering step. I am unsure where its coming from, since it seems like the output of cull-seqs is the same type of file that goes in.

Here is my code for this step:
qiime rescript cull-seqs
--i-sequences /local1/workdir1/tw488/CIDA_Sequencing_Runs/ITS_RUNS1_6_allinoneCOPY/Trimmomaticoutput/Pair_usethis/uchime-dn-out/rep-seqs-nonchimeric-wo-borderline.qza
--o-clean-sequences /local1/workdir1/tw488/CIDA_Sequencing_Runs/ITS_RUNS1_6_allinoneCOPY/Trimmomaticoutput/Pair_usethis/uchime-dn-out/rep-seqs-nonchimeric-wo-borderline-homopolyless.qza

qiime feature-classifier classify-sklearn
--i-classifier /local1/workdir1/tw488/CIDA_Sequencing_Runs/ITS_RUNS1_6_allinoneCOPY/Trimmomaticoutput/Pair_usethis/classifier.qza
--i-reads /local1/workdir1/tw488/CIDA_Sequencing_Runs/ITS_RUNS1_6_allinoneCOPY/Trimmomaticoutput/Pair_usethis/uchime-dn-out/rep-seqs-nonchimeric-wo-borderline-homopolyless.qza
--o-classification taxonomy.qza

Please let me know if you'd like to see more of my code or whatever else you need!

Many thanks,

@tamardigrade, can you try this:

qiime tools validate rep-seqs-nonchimeric-wo-borderline-homopolyless.qza

I ran that code and this is what happened:

Traceback (most recent call last):
File "/programs/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/q2cli/builtin/", line 535, in validate
result = qiime2.sdk.Result.load(path)
File "/programs/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/qiime2/sdk/", line 66, in load
archiver = archive.Archiver.load(filepath)
File "/programs/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/qiime2/core/archive/", line 302, in load
cls._futuristic_archive_error(filepath, archive)
File "/programs/miniconda3/envs/qiime2-2022.2/lib/python3.8/site-packages/qiime2/core/archive/", line 270, in _futuristic_archive_error
raise ValueError("%s was created by 'QIIME %s'. The currently"
ValueError: rep-seqs-nonchimeric-wo-borderline-homopolyless.qza was created by 'QIIME 2023.5.0'. The currently installed framework cannot interpret archive version '6'.

There was a problem loading rep-seqs-nonchimeric-wo-borderline-homopolyless.qza as a QIIME 2 Result:

rep-seqs-nonchimeric-wo-borderline-homopolyless.qza was created by 'QIIME 2023.5.0'. The currently installed framework cannot interpret archive version '6'.

See above for debug info.

So the way I've been processing my sequences is via QIIME on a server. Based on the code I use to activate the QIIME environment, this is version qiime2-2022.2. However for ReSCRIPT, I needed to install it on my home directory because I would run in to permissions errors if I tried to install and use it on the server. To activate QIIME on my home directory, I run the code 'conda activate qiime2-amplicon-2023.9.'

I'm guessing based off these errors I need to get BioHPC to update the QIIME on the server to 2023-9?

Please advise, and thanks a million for the fast response!


Hey @tamardigrade,

That's basically correct, yes!

So, you've essentially got the gist of it - the artifact you're attempting to use was created using the new v6 archive format for QIIME 2 Artifacts (created with versions >= 2023.5), which is not backwards compatible with older versions of QIIME 2 (i.e. versions that don't contain this new archive format).

You can either ask your HPC team to upgrade to the latest version of QIIME 2 (which is recommended, if possible) - otherwise you'd need to re-create that artifact using an older version of QIIME 2. The ladder option is not ideal, but that's what you'd need to do if for some reason your HPC team won't update the version of QIIME 2 that's available on that server.

Cheers :lizard:


Thanks so much for your quick responses, Liz and Mike!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.