Error from vsearch join-reads: exit code 1

I used 280 read length with Deblur. However, Deblur only supports forward reads. So I am trying to join reads now. I have problems with this. I use qiime2-2017.12 version and tried following command (my artifact paired-end-demux.qza) and received this error code:

qiime vsearch join-pairs
--i-demultiplexed-seqs paired-end-demux.qza
--o-joined-sequences demux-joined.qza

Hi @Jasmine84, can you please provide the full error log (listed in that terminal as Debug info has been saved to ...), or, re-run with the --verbose flag and copy-and-paste the complete output here. Thanks! :t_rex:

I works now. I removed the sample-id 50 that only had reads for forward but not reverse. However, the quality scores looks really good (660 bp long joined reads) and I am using Deblur for denoising with trimming length 590 bp, and I received the error "no sequences passed through the filter". I am running the job now with length 500 bp instead to see if that works. Is that the way to solve the problem, trying with different lengths? Is it because no sequences are 600 bp long that length did not work the first time?

qiime quality-filter q-score-joined
--i-demux demux-joined.qza
--o-filtered-sequences demux-joined-filtered.qza
--o-filter-stats demux-joined-filter-stats.qza
(The command above worked)

qiime deblur denoise-16S
--i-demultiplexed-seqs demux-joined-filtered.qza
--p-trim-length 590
--o-representative-sequences rep-seqs.qza
--o-table table.qza
--p-sample-stats
--o-stats deblur-stats.qza

Plugin error from deblur:

No sequences passed the filter. It is possible the trim_length (%d) may exceed the longest sequence, that all of the sequences are artifacts like PhiX or adapter, or that the positive reference used is not representative of the data being denoised.

Debug info has been saved to /tmp/qiime2-q2cli-err-z60q2eq9.log

Hi @Jasmine84, I think you’re correct that your trim length was set too high originally. Did it work when you re-ran with a lower value? If you’re still having trouble, can you share the .qzv file that contains the visualization you posted the screenshot of? I’d like to take a look at the quality plot interactively.

Deblur denoising works with 450 bp length. I have tried different lengths (e.g. 480, 500, 550, 590) but the result of the longer trimming sequences has been feature table with 0 samples included (no error info at 480 and 500, but for 550 and 590 “no sequences past thorugh filter”. I just wonder how this is possible - that no sequences at all runs through the denoising with Deblur with some of the longer trimming-lengths as I can see in my the interactive plot, the quality is good for 600 bp (maximum sequencing length is 600 bp = joined forward and reverse reads).

The taxonomy is better with 450 bp with more featureIDs to genus level, however, I hope that it can further improve when I train my classifier today from your tutorials.

Best regards

Hi @Jasmine84, I think what you’ll probably see in the demux summary is that there are many fewer sequences at the longer sequence lengths. I’m not sure why they would all be dropped, but it’s possible that the longer sequences are lower quality than the shorter ones. If you share your demultiplex summary qzv file (which you have the screenshot for above) I might be able to get a better idea of what’s happening.

demux-joined.qzv (288.5 KB)

here you are :slight_smile:

Would it make sense to trim (with e.g. trimmomatic or similar) before merging the reads? I guess one can tweak the trimming parameters more easily.

Hi @Jasmine84,

See this tutorial. In particular, see this section. It looks like many of your reads are failing to merge, and hence you have many reads that are only ~35 nt long. Such short reads may be garbage anyway — but it probably indicates that some sort of quality filtering is being done that is truncating reads, either by you or by the sequencing center. If you aren’t filtering these reads to trim based on quality, you may want to discuss with the sequencing center and get your full, raw reads.

This will all depend on how many reads you are obtaining after denoising, and if these levels are acceptable. deblur generates a log that you can use to determine input vs. output sequences for each sample. If you are losing many sequences at the length cutoff step, that may indicate a problem with reads exceeding the minimum length threshold — in which case you will want the raw data from the sequencer. If you are still getting enough reads out the other end, then these trimmed reads are not in the majority and you can probably proceed with what you have.

You do not need any external tools. You can use q2-quality-filter to trim based on quality scores (which I think may already be happening at some stage in your data) or q2-cutadapt to trim primers/adapters. And setting read length in deblur will just be easier overall.

Good luck!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.