Error during primer trimming

Hi Qiime2

Upon passing the following command

qiime cutadapt trim-paired --i-demultiplexed-sequences /Volumes/ARMS/COI/Run1_all_data/demux_qiime/R1_1/per_sample_sequences.qza --p-cores 8 --p-front-f GGWACWGGWTGAACWGTWTAYCCYCC --p-front-r TAIACYTCIGGRTGICCRAARAAYCA --o-trimmed-sequences demux_trimmed.qza

this error came up.

Plugin error from cutadapt:

Command ‘[‘cutadapt’, ‘–cores’, ‘8’, ‘–error-rate’, ‘0.1’, ‘–times’, ‘1’, ‘–overlap’, ‘3’, ‘-o’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/q2-CasavaOneEightSingleLanePerSampleDirFmt-s5ozxuw3/JBI01BDMSOM1_ATCGAC_L001_R1_001.fastq.gz’, ‘-p’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/q2-CasavaOneEightSingleLanePerSampleDirFmt-s5ozxuw3/JBI01BDMSOM1_ATCGAC_L001_R2_001.fastq.gz’, ‘–front’, ‘GGWACWGGWTGAACWGTWTAYCCYCC’, ‘-G’, ‘TAIACYTCIGGRTGICCRAARAAYCA’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/qiime2-archive-tuc9lfix/281735d3-8953-4a79-b872-6b693b18eb5c/data/JBI01BDMSOM1_ATCGAC_L001_R1_001.fastq.gz’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/qiime2-archive-tuc9lfix/281735d3-8953-4a79-b872-6b693b18eb5c/data/JBI01BDMSOM1_ATCGAC_L001_R2_001.fastq.gz’]’ returned non-zero exit status 2

Debug info has been saved to /var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/qiime2-q2cli-err-_1jh8hhs.log

the artifact file for this command is generated through “qiime tools import --type MultiplexedPairedEndBarcodeInSequence” and “qiime cutadapt demux-paired”. Also this is a dual indexing COI samples.

Iam not really sure what happened, would be good to hear from folks if they have any ideas on this.

Best
Aji

Hey there @ajiwahyu! Can you please send along the full output when run with the addition of the --verbose flag? Thanks! :qiime2:

Thanks Dillon @thermokarst !

I just found out that I is unacceptable ambiguous base as this is not an official IUPAC character based on --verbose error report. A friend has suggested to replace I with N, any comments on this.

This is the output of verbose flag

cutadapt: error: Character ‘I’ in adapter sequence ‘TAIACYTCIGGRTGICCRAARAAYCA’ is not a valid IUPAC code. Use only characters XACGTURYSWKMBDHVN.
Traceback (most recent call last):
File “/Users/IBRC/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/q2cli/commands.py”, line 274, in call
results = action(**arguments)
File “”, line 2, in trim_paired
File “/Users/IBRC/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 232, in bound_callable
output_types, provenance)
File “/Users/IBRC/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 367, in callable_executor
output_views = self._callable(**view_args)
File “/Users/IBRC/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/q2_cutadapt/_trim.py”, line 174, in trim_paired
run_commands(cmds)
File “/Users/IBRC/anaconda/envs/qiime2-2018.6/lib/python3.5/site-packages/q2_cutadapt/_trim.py”, line 30, in run_commands
subprocess.run(cmd, check=True)
File “/Users/IBRC/anaconda/envs/qiime2-2018.6/lib/python3.5/subprocess.py”, line 398, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command ‘[‘cutadapt’, ‘–cores’, ‘8’, ‘–error-rate’, ‘0.1’, ‘–times’, ‘1’, ‘–overlap’, ‘3’, ‘-o’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/q2-CasavaOneEightSingleLanePerSampleDirFmt-wr71hnwx/JBI01BDMSOM1_ATCGAC_L001_R1_001.fastq.gz’, ‘-p’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/q2-CasavaOneEightSingleLanePerSampleDirFmt-wr71hnwx/JBI01BDMSOM1_ATCGAC_L001_R2_001.fastq.gz’, ‘–front’, ‘GGWACWGGWTGAACWGTWTAYCCYCC’, ‘-G’, ‘TAIACYTCIGGRTGICCRAARAAYCA’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/qiime2-archive-khmw5aqg/281735d3-8953-4a79-b872-6b693b18eb5c/data/JBI01BDMSOM1_ATCGAC_L001_R1_001.fastq.gz’, ‘/var/folders/vs/0vv4fwcd6936b33m07w7ylwc0000gn/T/qiime2-archive-khmw5aqg/281735d3-8953-4a79-b872-6b693b18eb5c/data/JBI01BDMSOM1_ATCGAC_L001_R2_001.fastq.gz’]’ returned non-zero exit status 2

Best
Aji

Hey there @ajiwahyu!

I don't know of any tools to do this automatically, but you could craft an awk or grep/sed command to do this substitution.

Keep us posted! :qiime2: :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.